幻灯片工作簿

幻灯片工作簿是内置在 PowerPoint 幻灯片中的完整 Excel 工作簿。您可以使用幻灯片工作簿执行以下操作:

  • 在一个位置管理幻灯片上所有 thinkcell 图表和其他元素的数据。
  • 添加不想显示在幻灯片上的备注和计算。
  • 基于同一数据区域创建图表和表格(请参阅 将图表数据复制为表格)。
  • 将幻灯片工作簿作为 Excel 文件保存到您的计算机。

打开幻灯片工作簿

要打开幻灯片工作簿,请在 PowerPoint 功能区中选择 Insert > thinkcell > Tools 工具菜单图标 > Slide Workbook 。在您编辑幻灯片时,幻灯片工作簿会保持打开状态。关闭工作簿时,thinkcell 会自动保存您的更改。

要跳转到幻灯片工作簿中某个元素数据的位置,请执行以下任一操作:

  • 图表:双击图表。或者,选择图表,然后选择 Open Datasheet 。
  • 其他元素:右键单击该元素,然后选择 Open Datasheet 。

您可以在幻灯片上的元素与该幻灯片的工作簿之间创建 Excel 数据链接(请参阅 Excel 数据链接)。一个幻灯片工作簿只能包含指向其关联幻灯片上元素的链接。

链接到幻灯片工作簿的元素不会显示在 Data Links 对话框中(请参阅 使用 Data Links 对话框管理已链接数据)。

您可以通过以下方式将元素链接到幻灯片工作簿:

从幻灯片工作簿数据创建元素

要在幻灯片上插入一个链接到幻灯片工作簿的元素,请按以下步骤操作:

  1. 在 PowerPoint 功能区中,选择 Insert > thinkcell > Tools 工具菜单图标 > Slide Workbook 。
  2. 在幻灯片工作簿中,输入该元素的数据。如果要创建图表,请确保您的数据符合该图表的数据布局。

    如果不确定该图表的数据布局,请插入所需的图表,将其链接到幻灯片工作簿(请参阅 将现有元素链接到幻灯片工作簿),然后用您自己的数据替换默认数据。跳过本节其余步骤。
  3. 选择数据。
  4. 在幻灯片工作簿的功能区中,在 Insert 选项卡上打开 Link to PowerPoint 菜单。然后选择要插入的元素。
  5. 在幻灯片上,单击要插入元素的位置。

要将现有元素链接到幻灯片工作簿,请按以下步骤操作:

  1. 如果该元素已链接到 Excel 文件,请先移除链接(请参阅 移除数据链接)。
  2. 打开该元素的数据表(请参阅 元素数据表)。
  3. 在数据表工具栏上,选择 Move Data to Slide Workbook 。

每次将元素链接到幻灯片工作簿时,thinkcell 都会在工作簿中创建一个新工作表,并将数据插入其中。如果您随后将数据剪切并粘贴到其他工作表,粘贴的数据仍会链接到该元素。

将元素数据从幻灯片工作簿移至 Excel 文件

您可以将单个元素的数据移至 Excel 文件,也可以将整个幻灯片工作簿另存为 Excel 文件。

将元素数据移至 Excel 文件

要将元素的链接数据从幻灯片工作簿移至外部 Excel 文件,请按以下步骤操作:

  1. 移除该元素的 Excel 链接(请参阅 移除数据链接)。
  2. 将数据复制到 Excel 文件。
  3. 将 Excel 文件中的数据链接到该元素(请参阅 Excel 数据链接)。

将幻灯片工作簿另存为 Excel 文件

要在当前幻灯片之外共享和使用幻灯片工作簿,请将幻灯片工作簿另存为 Excel 文件。Excel 文件中的数据不会链接到您的元素。

要将幻灯片工作簿另存为 Excel 文件,请在幻灯片工作簿的工具栏上选择 File > Save As。为文件命名并选择保存位置。要了解更多信息,请参阅保存工作簿。

移除幻灯片工作簿

您可以从演示文稿中移除一个或多个幻灯片工作簿。在将元素数据移至 Excel 文件之后,或在共享演示文稿之前,您可能需要移除幻灯片工作簿。

移除幻灯片工作簿时,工作簿中的元素数据及其格式会移至元素的数据表。此规则适用于除表格图像之外的所有元素(请参阅 创建表格图像);移除其幻灯片工作簿时,表格图像会丢失数据。

要从演示文稿中移除幻灯片工作簿,请参阅 清理和净化。

若要在发送或保存幻灯片时移除幻灯片工作簿,请参阅 发送和保存幻灯片。


若要了解如何使用幻灯片工作簿更灵活地构建数据密集型演示文稿,请阅读这篇博客文章。

需要排查问题吗?

查看我们的知识库