管理数据链接

本页说明如何管理 PowerPoint 与外部数据源之间的数据链接,例如调整已链接的 Excel 区域、使用新数据更新单个已链接元素,以及通过 Data Links 对话框管理演示文稿中所有已链接元素的更新。

要了解如何在 Excel 和 PowerPoint 之间创建数据链接,请参阅 Excel 数据链接。要了解如何在 Tableau 和 PowerPoint 之间创建和管理数据链接,请参阅 Tableau 数据链接。

数据链接术语

下表定义了本页中出现的特定术语。

术语

定义

备用数据源

thinkcell 识别为与现有数据链接匹配的工作簿或工作表,但该现有数据链接使用的是另一个工作簿或工作表(例如,在工作簿或工作表的名称或位置发生变化后)。

自动更新

一种数据更新选项:每当 thinkcell 检测到已链接 Excel 区域发生变化时,已链接元素会自动使用新数据更新。

数据链接

PowerPoint 中的 thinkcell 元素与 Excel 或 Tableau 数据源之间的关系,可使用数据源中的数据更新该元素。

数据源

包含 thinkcell 用于更新 PowerPoint 中已链接元素的数据的 Excel 工作簿或工作表,或 Tableau 视图。

已链接 Excel 区域

Excel 中为 PowerPoint 中的已链接元素提供数据的单元格区域。

数据链接框

显示在 Excel 中已链接单元格区域周围、用于指示数据链接状态的框。

恢复数据链接

指 thinkcell 连接到数据源,以恢复该数据源与 PowerPoint 中已链接元素之间已存在但已断开的数据链接(例如,在重启设备后)。

还原

一种数据更新选项,用于撤销对已链接元素最近一次的数据更新,并将其恢复为上一组数据。

在 PowerPoint 中,您可以使用来自 Excel 的新数据更新已链接元素,撤销已链接元素中的最新数据更新,或让 thinkcell 在有新数据时自动更新已链接元素。以下各节说明如何逐个管理已链接元素中的数据:

要更新 PowerPoint 中的已链接元素,thinkcell 必须连接到包含已链接区域的 Excel 工作簿。为建立此连接,thinkcell 会使用以下有关 Excel 工作簿的信息:

  • Excel 工作簿的名称和文件路径
  • 包含已链接数据区域的工作表名称

当您选择幻灯片上的已链接元素时,其已链接工作簿和工作表的信息会显示在该元素上方。

要了解当 thinkcell 尚未连接到已链接元素的 Excel 数据区域时如何管理这些元素,请参阅以下各节:

当已链接元素的已链接 Excel 区域中有新数据时,该元素周围的选择框会变为绿色,并且 Update 按钮会显示在元素上方。

要使用新数据更新该元素,请选择 Update 。或者,选择该元素以打开迷你工具栏,然后选择 Update Once 。

Mini toolbar of linked thinkcell chart with update pending

当您更新已链接元素时,thinkcell 会保存这些元素之前的数据集,直到您关闭演示文稿。要撤销对已链接元素的最后一次数据更新,请选择该元素以打开迷你工具栏,然后选择 Revert 。

您可以使用 Update Once 和 Revert 按钮,在已链接元素的最近一次数据更新与之前的数据之间切换,即使与已链接 Excel 工作簿的数据链接已断开也可以。

您可以允许 thinkcell 连接到已链接 Excel 区域,并在 Excel 中的数据发生变化时自动更新已链接元素。为此,请选择该元素以打开迷你工具栏,然后选择 Update Automatically 。

只要 thinkcell 能够连接到已链接 Excel 区域,已链接 Excel 区域中的任何更改都会自动显示在已链接元素中(请参阅 恢复已断开的数据链接)。

要停止已链接元素的自动更新,请选择该元素以打开迷你工具栏,然后选择 Disable Automatic Update 或 Revert 。

当已链接元素与其已链接 Excel 区域之间的数据链接断开时,橙色问号( 橙色问号 )会出现在以下位置:

  • 选择元素时,显示在元素上方。
  • 显示在元素的迷你工具栏中,位于 Reverted 按钮上。
    • 如果您为该元素选择了自动更新,则橙色问号会改为显示在 Automatic Update Enabled 按钮上。
  • 在 Data Links 对话框中,显示在已链接元素的数据源旁边(请参阅 使用 Data Links 对话框管理已链接数据)。

要恢复演示文稿中已断开的数据链接,请按以下步骤操作:

  1. 选择该元素。
  2. 选择以下其中一项:
    • 在迷你工具栏上,选择 Update Once 或 Update Automatically 。
    • 选择 Open Datasheet 。或者,双击该元素。

如果 thinkcell 能够连接到已链接 Excel 区域,它会恢复数据链接,橙色问号也会消失。根据您的选择,该元素会更新,或已链接 Excel 区域会打开。

如果 thinkcell 无法连接到已链接 Excel 区域,红色感叹号( 红色叹号 )会取代橙色问号。如果您选择了 Open Datasheet (或双击了该元素),则会改为打开元素数据表。要了解更多信息,请参阅 当 thinkcell 无法连接到已链接 Excel 区域时恢复已断开的数据链接 和 不使用 Excel 数据源管理已链接元素中的数据。

当 thinkcell 无法连接到已链接 Excel 区域以恢复数据链接时,红色感叹号( 红色叹号 )会取代已链接元素上方和更新按钮上的橙色问号。常见原因包括已链接工作簿或工作表的名称或位置发生变化。

当已链接工作簿或工作表的名称或位置发生变化时,您可以手动恢复已断开的数据链接。为此,请替换已链接元素的数据源(请参阅 切换到备用数据源)。

不使用 Excel 数据源管理已链接元素中的数据

当 thinkcell 无法恢复数据链接时,您仍然可以使用元素数据表管理已链接元素中的数据(请参阅 元素数据表)。为此,请选择该元素,然后选择 Open Datasheet 。或者,双击该元素。元素数据表会打开,其中包含最近一次使用的已链接 Excel 区域数据副本。

如果您之后将该元素链接到 Excel 区域,则您通过元素数据表在元素中所做的更改,在使用已链接 Excel 数据更新该元素之前不会改变。为确保您通过元素数据表在元素中所做的更改不会被覆盖,thinkcell 会在您打开并编辑已链接元素的元素数据表时,禁用这些元素的自动更新。

使用 Data Links 对话框管理已链接数据

当演示文稿中有许多已链接元素时,逐个管理其数据可能不太实际。Data Links 对话框可为您提供演示文稿中所有数据链接的概览,并允许您同时管理多个已链接元素。

要打开 Data Links 对话框,请在 PowerPoint 功能区中,转到 Insert > thinkcell > Tools 工具菜单图标 ,然后选择 Data Links 。或者,选择一个已链接的元素以打开迷你工具栏,然后选择 Open Data Links Dialog 。

对话框左侧会按如下方式列出演示文稿中的已链接元素:

对话框右侧会列出已链接的数据源。每个数据源会显示在第一个包含链接到该数据源的元素的幻灯片旁边。该列表按如下方式显示数据源:

  • Excel 数据源会按工作簿分组显示:
    • 首先显示工作簿文件名和位置。
    • 在每个工作簿下,该工作簿中的已链接工作表会以列表形式显示。
  • Tableau 数据源会显示为 URL(请参阅 Tableau 数据链接)。

将鼠标悬停在幻灯片缩略图中的元素占位符上时,该元素链接的数据源会在列表中高亮显示。工具提示会显示工作表名称、工作簿文件路径、元素当前的更新状态,以及该元素上次从 Excel 接收新数据的时间。

如果选择元素占位符,对话框中的已链接数据源和幻灯片上的实际元素也会被选中,并且包含该元素的幻灯片会打开。数据源上方会出现一个带有数据更新按钮的浮动工具栏。你可以在 Data Links 对话框中使用更新按钮来更新已链接元素,方式与在幻灯片上逐个更新它们相同(请参阅 管理已链接元素中的数据)。你也可以选择多个已链接元素并同时管理它们的更新(请参阅 选择并管理多个已链接元素)。

要打开某个元素链接的 Excel 区域,请在幻灯片缩略图列表中双击该元素的占位符。如果 thinkcell 无法连接到已链接的 Excel 工作簿或工作表,在对话框中,该工作簿或工作表旁会显示红色问号,并会改为打开该元素的数据表(请参阅 不使用 Excel 数据源管理已链接元素中的数据)。

要高亮显示演示文稿中的所有已链接元素,请选择 Highlight on Slide。演示文稿中的所有已链接元素都会出现绿色高亮。如果希望某个元素保持高亮,请选择该元素占位符,然后在浮动工具栏上选择 Always Highlight on Slide。

选择并管理多个已链接元素

你可以在 Data Links 对话框中选择多个已链接元素,然后使用数据更新按钮同时管理所选元素(请参阅 管理已链接元素中的数据)。

要选择多个已链接元素,请执行以下任一操作:

  • 在右侧列中选择一个数据源,以选择链接到该数据源的所有元素。
  • 选择一个幻灯片缩略图,以选择该幻灯片上的所有已链接元素。
  • 按住 Ctrl,然后选择多个元素、幻灯片缩略图或数据源。
  • 按住 Shift,然后选择一系列幻灯片缩略图或数据源。
  • 选择 Ctrl+A 或 Select All Linked Elements,以选择演示文稿中的所有已链接元素。

选择多个已链接元素后,你可以筛选所选内容,使其仅包含特定的已链接元素,例如从所选内容中移除已经更新的元素。要筛选所选内容,请使用以下 Filter Selection 复选框:

  • :不包含最新已链接 Excel 数据的元素,以及数据链接已断开的元素(请参阅 恢复已断开的数据链接)。
  • :已更新的元素。
  • :已启用自动更新的元素。
  • :链接到 Tableau 的元素(请参阅 Tableau 数据链接)。

选择所需的已链接元素后,你可以使用浮动工具栏上的数据更新按钮来管理所选元素中的数据。

切换到备用数据源

有时,你需要更改与 PowerPoint 中元素建立了数据链接的 Excel 工作簿。如果你重命名、移动或复制包含已链接区域的工作簿或工作表,thinkcell 不会自动切换到更改后的数据源来更新数据链接。相反,更改后的数据源会成为这些已链接元素的备用源。

在 Data Links 对话框中,备用源会显示在 Data Source 下拉菜单中。当 thinkcell 首次检测到新的备用源时,以下位置会出现指示标记:

  • 在 thinkcell 功能区的 Data Links 按钮图标上。
  • 在 Data Links 对话框中,显示在具有新备用源的已列出数据源旁边,以及 Data Source 下拉菜单旁边。

要将已链接元素的数据源切换到备用源,请按以下步骤操作:

  1. 在 Data Links 对话框中,选择你希望如何切换源:
    • 要将某个已链接元素切换到备用源,请选择该元素占位符。
    • 要将某张幻灯片上的所有已链接元素切换到备用源,请选择该幻灯片缩略图。
    • 要将使用同一工作簿或工作表作为源的所有已链接元素切换到备用源,请选择该工作簿或工作表。
  2. 打开 Data Source 下拉菜单。
  3. 在下拉菜单中,选择备用源。

你可以从 PowerPoint 或 Excel 中移除元素与 Excel 区域之间的数据链接。移除数据链接只会结束 PowerPoint 中某个特定元素与其在 Excel 中链接的单元格区域之间的关系。在 Excel 中,单元格内容不会改变;在 PowerPoint 中,该元素会保留在演示文稿中,并使用其最近的数据集。

当你在 PowerPoint 中从已链接元素移除数据链接时,已链接的 Excel 区域仍会保留它与其他已链接元素之间的数据链接。同样,当你从已链接的 Excel 区域移除数据链接时,链接到该区域的元素会保留其数据链接,但不能再使用该特定区域更新数据。你仍然可以更改它们的数据源,并继续将其作为已链接元素使用(请参阅 切换到备用数据源)。

要从 PowerPoint 中的已链接元素移除数据链接,请右键单击该元素以打开上下文菜单,然后选择 Break Excel Link image 。你也可以在一张幻灯片上选择多个已链接元素,并以相同方式移除它们的数据链接(请参阅 选择对象)。

thinkcell deleting external data-links

你可以通过在 Data Links 对话框中删除列出的数据源,同时移除演示文稿中的多个数据链接(请参阅 使用 Data Links 对话框管理已链接数据)。为此,请在对话框中选择要移除的工作簿或工作表,然后选择 Del(请参阅 选择并管理多个已链接元素)。

要从 Excel 中的已链接区域移除数据链接,请右键单击已链接区域周围的边框以打开上下文菜单,然后选择 Delete 删除图标 。

在 Excel 中,你可以移除所有数据链接已断开的已链接区域中的数据链接。为此,请在 Excel 功能区中,转到 Insert > thinkcell > Tools 工具菜单图标 ,然后选择 Delete Disconnected Links 。或者,右键单击已链接区域周围的红色边框以打开上下文菜单,然后选择 Delete Disconnected Data Links 删除断开的数据链接图标 。

Excel 数据链接常见问题

复制已链接元素时会发生什么?

复制已链接元素时,原始元素和副本都会链接到同一个 Excel 数据区域,并以相同方式接收数据更新(请参阅 管理已链接元素中的数据)。

删除已链接元素时会发生什么?

删除已链接元素时,你也会一并移除它与 Excel 的数据链接。如果打开的演示文稿中没有其他元素链接到同一个 Excel 数据区域,则已链接 Excel 区域周围的边框会变为红色。除此之外,该已链接区域不会受到任何其他影响。要了解更多信息,请参阅 移除数据链接。

如何去掉 Excel 工作表中的红色边框?

已链接区域周围的红色边框表示数据链接已断开,也就是说,当前没有打开的演示文稿使用该已链接区域建立数据链接。但这并不一定意味着没有已链接元素使用该单元格区域。

你可以通过移除数据链接来移除已链接区域周围的边框。在 Excel 区域中移除数据链接不会影响该区域中的数据。要移除所有数据链接已断开的已链接区域中的数据链接,请在 Excel 功能区中,转到 Insert > thinkcell > Tools 工具菜单图标 ,然后选择 Delete Disconnected Links 。或者,右键单击已链接区域周围的红色边框以打开上下文菜单,然后选择 Delete Disconnected Data Links 删除断开的数据链接图标 。要了解更多信息,请参阅 移除数据链接。

为什么 Excel 数据没有变化,但我的已链接元素仍显示有待处理更新?

即使是 Excel 数据中的细微变化,例如小数分隔符或货币符号的变化,也会被已链接元素识别为新数据。

如果你确定已链接的 Excel 区域中没有新数据,但仍看到某个已链接元素有待处理更新,请检查该元素的数据表是否有任何数据变化。要了解如何使用元素数据表更改已链接元素中的数据,请参阅 不使用 Excel 数据源管理已链接元素中的数据。

你可以通过禁用自动错误检查来提升 Excel 性能。为此,请按以下步骤操作:

  1. 在 Excel 功能区中,转到 File > Excel Options。
  2. 在 Excel Options 对话框中,选择 Formulas 选项卡。
  3. 在 Error Checking 部分,取消 Enable background error checking。

我有很多 Excel 文件需要用 thinkcell 可视化。可以以批处理模式运行 thinkcell 吗?

可以,thinkcell 提供相关功能,可通过编程方式使用 Excel 区域中的数据更新图表,并根据模板创建完整的演示文稿。要了解更多信息,请参阅 使用 Excel 数据实现自动化。

与 Microsoft OLE 相比,数据链接有哪些优势?

你可能熟悉 Microsoft Office 中的 OLE(对象链接与嵌入)。OLE 与 thinkcell 的数据链接有些相似,都可以在 PowerPoint 中创建图表,并使用 Excel 中的数据进行更新。不过,与 OLE 相比,thinkcell 的链接技术有多项优势:

  • 无论图表是否已链接,它们始终保持一致。即使是已链接图表,也是原生 PowerPoint 对象,而不是粘贴到 PowerPoint 中的 Excel 图表。特别是,图表所基于的数据也会存储在演示文稿中,即使链接的文件不可用,也可以查看和编辑。
  • 图表可以随时链接到 Excel,而不仅限于创建时。
  • 即使已链接的数据源不可用,已链接图表仍可编辑。

需要排查问题吗?

查看我们的知识库