配置 PowerPoint 和 Excel 功能区

  1. Home
  2. 资源
  3. 用户手册
  4. 部署指南
  5. 配置 PowerPoint 和 Excel 功能区

thinkcell 为 PowerPoint 和 Excel 提供了许多功能区控件,即选项卡、组和命令。例如,默认的 thinkcell 功能区选项卡包含 thinkcell 控件和内置 Office 控件,并按从左到右的顺序组织,以体现创建演示文稿 (PowerPoint) 和处理数据 (Excel) 的流程。作为管理员,您可以为组织中的用户配置功能区上的 thinkcell 控件、内置 Office 控件以及其他加载项的控件。

在 Windows 上,可使用组策略配置功能区(请参阅 组策略),或在安装期间使用命令行参数进行配置(请参阅 在 Windows 上安装)。

在 Mac 上,可使用 defaults 命令行工具配置功能区(请参阅 在 macOS 上安装),或使用设备管理解决方案进行配置(请参阅 macOS 上的托管部署)。

使用 .officeUI 文件配置功能区选项卡

仅限 Windows

在 Windows 上,管理员可以使用 .officeUI XML 文件在整个组织中配置和部署自定义功能区选项卡。作为管理员,您可以使用 thinkcell 控件、内置 Office 控件和其他加载项控件的任意组合,配置 thinkcell 功能区选项卡或其他自定义选项卡。若要以标准用户身份自定义功能区,请参阅 自定义 thinkcell 功能区控件。

每次打开 PowerPoint 或 Excel 时,thinkcell 都会加载您的 .officeUI 选项卡配置。通常,thinkcell 会保留用户自己的功能区自定义设置,例如快速访问工具栏和其他功能区选项卡。但是,如果您配置了 thinkcell 选项卡,而用户也在 PowerPoint 中自定义了 thinkcell 选项卡,则您的配置将覆盖用户的自定义设置。如果用户选择 Tools 工具菜单图标 > Restore thinkcell Tab ,thinkcell 会加载您的 XML 文件中指定的自定义选项卡,并覆盖任何冲突的用户功能区自定义设置。

.officeUI 选项卡配置会覆盖默认 thinkcell 选项卡的位置和标签配置(请参阅 配置默认 thinkcell 选项卡的位置和标签)。

要配置自定义选项卡,请按以下步骤操作:

  1. 为自定义选项卡创建 XML 文件。
  2. 部署自定义选项卡。

如果您想向功能区添加多个自定义选项卡,请联系我们的支持团队。

为自定义选项卡创建 XML 文件

要创建一个用于编码自定义选项卡的 XML 文件,请按以下步骤操作:

  1. 安装 thinkcell 后,打开您想要自定义选项卡的应用,即 PowerPoint 或 Excel。
  2. 右键单击功能区并选择 Customize the Ribbon。
  3. 在 Customize the Ribbon 中,自定义 thinkcell 选项卡或创建新的自定义选项卡。您可以在 Customize the Ribbon 列表中找到 thinkcell (Custom),即 thinkcell 选项卡。要创建新的自定义选项卡,请选择 New Tab。

    您的选项卡可以包含 thinkcell 控件、内置 Office 控件和其他加载项控件的任意组合。要查看所有 thinkcell 功能区命令,请打开 Choose commands from 下拉菜单并选择 Main Tabs。在 Choose commands from 列表中的 Main Tabs 下,打开 thinkcell Commands > thinkcell Commands。

    您可以自定义选项卡在功能区上的位置、UI 标签和控件。更多信息,请参阅 Microsoft 支持。

    完成后,选择 OK。

  4. 关闭应用。
  5. 在文件资源管理器中,转到 %AppData% 或 %LocalAppData%,具体取决于 Office 用户自定义设置是漫游还是本地设置。在 Microsoft\Office 子文件夹中,复制带有自定义选项卡的应用的 .officeUI 文件,即 PowerPoint.officeUI 或 Excel.officeUI。我们建议您重命名复制的文件,例如命名为 think-cell.officeUI。

如果您自行编写 .officeUI 文件,请确保以下事项:

  • 该文件采用标准 Custom UI XML 格式(请参阅 Microsoft Learn)。
  • 自定义选项卡的 ID 为 ThinkCellTab0。

部署自定义选项卡

创建好用于编码自定义选项卡的 .officeUI XML 文件后,请将该文件部署到所有用户的相同路径,例如 C:\Program Files (x86)\think-cell\customizations\think-cell.officeUI。为了加载自定义选项卡,组织中的用户每次打开 PowerPoint 或 Excel 时都必须能够访问该 XML 文件。

然后,使用组策略或安装命令行参数,指定 XML 文件的路径。该路径可以是相对于 thinkcell 安装文件夹的相对路径,也可以是绝对路径。

组策略

要使用 组策略 部署您的自定义选项卡,请按以下步骤操作:

  1. 打开您要配置的应用的 thinkcell Tab 设置,即 PowerPoint thinkcell Tab 或 Excel thinkcell Tab。
  2. 选择 Enabled。
  3. 在 File path 中,输入 .officeUI 文件的路径,例如 customizations\think-cell.officeUI。请勿用引号括起该路径。
  4. 选择 OK。

要移除自定义选项卡,请选择 Not Configured,然后选择 OK。

安装命令行

若要使用安装命令行参数部署自定义选项卡(请参阅 在 Windows 上安装),请使用参数 RIBBONPPCUSTOMTHINKCELLTAB (PowerPoint) 或 RIBBONXLCUSTOMTHINKCELLTAB (Excel) 运行 thinkcell 安装文件。将该参数设置为 .officeUI 文件的路径。

例如,若要使用 thinkcell 安装文件夹中的 XML 文件 customizations\think-cell.officeUI 在 PowerPoint 中部署自定义选项卡,请使用以下命令行参数:

RIBBONPPCUSTOMTHINKCELLTAB=customizations\think-cell.officeUI

若要移除自定义选项卡,请运行 thinkcell 安装文件,并将参数设置为 ""。例如,若要从 PowerPoint 中移除该选项卡,请使用以下参数:

RIBBONPPCUSTOMTHINKCELLTAB=""

配置默认 thinkcell 选项卡的位置和标签

仅限 Windows

在 Windows 上,作为管理员,您可以配置 PowerPoint 和 Excel 中 thinkcell 选项卡的功能区位置和 UI 标签。为此,请在 thinkcell 配置参数中指定用于编码所需配置的 XML 属性。

如果您还配置了自定义功能区选项卡(请参阅 使用 .officeUI 文件配置功能区选项卡),自定义选项卡将覆盖 thinkcell 选项卡配置。

若要指定默认 thinkcell 选项卡的位置和标签,请使用下表中的配置参数。指定配置参数后,若要将更改更新到功能区,请打开 PowerPoint 或 Excel,并选择 Tools 工具菜单图标 > Restore thinkcell Tab 。

指定命令行参数时,请将 XML 代码放在引号(" ")中,并将属性值放在两组引号("" "")中。例如,在命令行中,将 XML 代码 insertAfterMso="TabHome" 输入为 "insertAfterMso=""TabHome"""。

Group policy 选项

命令行参数

可用属性

说明

PowerPoint:
PowerPoint thinkcell Tab > <tab

Excel:
Excel thinkcell Tab > <tab

PowerPoint:
RIBBONPPTHINKCELLTABINSERT


Excel:
RIBBONXLTHINKCELLTABINSERT

insertAfterMso, insertBeforeMso

在内置选项卡之后或之前插入 thinkcell 选项卡。

insertAfterQ, insertBeforeQ

在另一个自定义选项卡之后或之前插入 thinkcell 选项卡。需要 XML 命名空间声明(请参阅 使用 idQ 和 xmlns 定位自定义控件)。

label

指定 thinkcell 选项卡的 UI 标签。

xmlns:NS_ID

将 NS_ID 替换为命名空间标识符。

为自定义选项卡声明 XML 命名空间(请参阅 使用 idQ 和 xmlns 定位自定义控件)。

示例

本示例中的参数将配置以下内容:

  • 在 PowerPoint 功能区的 Home 选项卡之后插入默认 thinkcell 选项卡。
  • 将默认 thinkcell 选项卡的标签更改为 My New Tab。

组策略

若要使用 组策略 配置此示例,请按以下步骤操作:

  1. 打开组策略设置 PowerPoint thinkcell Tab。
  2. 选择 Enabled。
  3. 在 <tab 中,输入 insertAfterMso="TabHome" label="My New Tab"。
  4. 选择 OK。
  5. 在 PowerPoint 的 Insert 选项卡上,选择 Tools 工具菜单图标 > Reset thinkcell Tab 。

若要恢复默认 thinkcell 选项卡,请按以下步骤操作:

  1. 在组策略设置 PowerPoint thinkcell Tab 中,选择 Not Configured。
  2. 在 PowerPoint 的 Insert 选项卡上,选择 Tools 工具菜单图标 > Reset thinkcell Tab 。

安装命令行

若要使用安装命令行参数配置此示例(请参阅 在 Windows 上安装),请按以下步骤操作:

  1. 使用以下参数运行 thinkcell 安装文件:
RIBBONPPTHINKCELLTABINSERT="insertAfterMso=""TabHome"" label=""My New Tab"""
  1. 在 PowerPoint 的 Insert 选项卡上,选择 Tools 工具菜单图标 > Reset thinkcell Tab 。

若要恢复默认 thinkcell 选项卡,请按以下步骤操作:

  1. 使用以下参数运行 thinkcell 安装文件:
RIBBONPPTHINKCELLTABINSERT=""
  1. 在 PowerPoint 的 Insert 选项卡上,选择 Tools 工具菜单图标 > Reset thinkcell Tab 。

启用或禁用 thinkcell 选项卡

作为管理员,您可以启用或禁用 PowerPoint 和 Excel 中的 thinkcell 选项卡。禁用 thinkcell 选项卡时,thinkcell 还会隐藏 Reset thinkcell Tab (Windows) 和 Show thinkcell Tab (macOS),这些选项位于 Tools 工具菜单图标 菜单中。

若要启用或禁用 thinkcell 选项卡,请使用以下配置参数。

Windows

禁用 thinkcell 选项卡

若要在 Windows 上禁用 thinkcell 选项卡,请按以下步骤操作:

  1. 禁用 thinkcell 选项卡的加载。
  2. 从功能区中移除 thinkcell 选项卡。
1. 禁用 thinkcell 选项卡的加载

您可以使用组策略或安装命令行参数禁用 thinkcell 选项卡的加载。

若要使用 组策略 禁用 thinkcell 选项卡的加载,请按以下步骤操作:

  1. 打开要配置的应用对应的 thinkcell 选项卡设置,即 PowerPoint thinkcell Tab 或 Excel thinkcell Tab。
  2. 选择 Disabled。
  3. 选择 OK。

若要使用安装命令行参数禁用 thinkcell 选项卡的加载(请参阅 在 Windows 上安装),请使用相应参数运行 thinkcell 安装文件:

  • 禁用 PowerPoint thinkcell 选项卡:RIBBONPPNOTHINKCELLTAB=1
  • 禁用 Excel thinkcell 选项卡:RIBBONXLNOTHINKCELLTAB=1
2. 从功能区中移除 thinkcell 选项卡

若要从功能区中移除 thinkcell 选项卡,请按以下步骤操作:

  1. 打开要禁用其 thinkcell 选项卡的应用,即 PowerPoint 或 Excel。
  2. 右键单击功能区上的任意空白区域。选择 Customize the Ribbon。
  3. 在 Customize the Ribbon 中,移除选项卡 thinkcell (Custom)。有关更多信息,请参阅 Microsoft Learn。
  4. 关闭应用。

启用 thinkcell 选项卡

若要在 Windows 上启用 thinkcell 选项卡,请按以下步骤操作:

  1. 启用 thinkcell 选项卡的加载。
  2. 重置 thinkcell 选项卡。
1. 启用 thinkcell 选项卡的加载

您可以使用组策略或安装命令行参数启用 thinkcell 选项卡的加载。

若要使用 组策略 启用 thinkcell 选项卡的加载,请按以下步骤操作:

  1. 打开要配置的应用对应的 thinkcell 选项卡设置,即 PowerPoint thinkcell Tab 或 Excel thinkcell Tab。
  2. 选择 Not Configured 或 Enabled。
  3. 选择 OK。

若要使用安装命令行参数启用 thinkcell 选项卡的加载(请参阅 在 Windows 上安装),请使用相应参数运行 thinkcell 安装文件:

  • 启用 PowerPoint thinkcell 选项卡:RIBBONPPNOTHINKCELLTAB=0
  • 启用 Excel thinkcell 选项卡:RIBBONXLNOTHINKCELLTAB=0
2. 重置 thinkcell 选项卡

若要重置 thinkcell 选项卡,请按以下步骤操作:

  1. 打开要启用其 thinkcell 选项卡的应用,即 PowerPoint 或 Excel。
  2. 在功能区上,转到 Insert > thinkcell > Tools 工具菜单图标 。选择 Reset thinkcell Tab 。
macOS

若要在 Mac 上禁用 thinkcell 选项卡,请在 com.think-cell.settings.ribbonpp 或 com.think-cell.settings.ribbonxl 字典中,将 NoThinkCellTab 的布尔值设置为 true。

例如,若要使用 defaults 工具禁用 PowerPoint 中的 thinkcell 选项卡(请参阅 在 macOS 上安装),请使用以下命令:

sudo defaults write /Library/Preferences/com.microsoft.office.plist com.think-cell.settings.ribbonpp -dict-add NoThinkCellTab -bool true

若要通过用于设备管理解决方案的 .plist 文件执行相同操作(请参阅 macOS 上的托管部署),请使用以下代码:

<dict>
	<key>com.think-cell.settings.ribbonpp</key>
	<dict>
		<key>NoThinkCellTab</key>
		<true/>
	</dict>
</dict>

若要启用 thinkcell 选项卡,请将 NoThinkCellTab 的布尔值设置为 false。

仅在 thinkcell 组中显示 thinkcell 命令

仅限 Windows

在 PowerPoint 中,thinkcell 会向许多功能区选项卡和组添加命令。作为管理员,你可以将内置功能区选项卡上的 thinkcell 命令限制为 Insert 选项卡上的单个 thinkcell 组。此配置参数不会影响 thinkcell 选项卡。

组策略

若要使用 组策略 将 thinkcell 命令限制到 thinkcell 组,请按以下步骤操作:

  1. 打开组策略设置 PowerPoint Ribbon。
  2. 选择 Enabled。
  3. 选择 Do Not Touch Built-In Ribbon。
  4. 选择 OK。

若要将 thinkcell 命令恢复到其他功能区选项卡和组,请取消选择 Do Not Touch Built-In Ribbon。然后选择 OK。

安装命令行

若要使用安装命令行参数(请参阅 在 Windows 上安装)将 thinkcell 命令限制到 thinkcell 组,请使用参数 RIBBONPPDONOTTOUCHBUILTINRIBBON=1 运行 thinkcell 安装文件。

若要将 thinkcell 命令恢复到其他功能区选项卡和组,请使用参数 RIBBONPPDONOTTOUCHBUILTINRIBBON=0 运行 thinkcell 安装文件。

配置 thinkcell 组

仅限 Windows

作为管理员,你可以指定 thinkcell 组显示在哪个内置或自定义功能区选项卡上、该组在选项卡上的位置,以及该组的 UI 标签。

指定命令行参数时,请将 XML 代码放在引号(" ")中,并将属性值放在两组引号("" "")中。例如,在命令行中,将 XML 代码 idMso="TabHome" 输入为 "idMso=""TabHome"""。

有关配置 Office 功能区的更多信息,请参阅 Microsoft Learn。

配置 tab 元素

若要配置 thinkcell 组显示位置的 tab 元素,请使用以下配置参数。

Group policy 选项

命令行参数

可能的属性

说明

PowerPoint:
PowerPoint Ribbon > <tab

Excel:
Excel Ribbon > <tab

PowerPoint:
RIBBONPPTABINSERT

Excel:
RIBBONXLTABINSERT

idMso

将 thinkcell 组插入到内置选项卡上。

id, idQ

将 thinkcell 组插入到自定义选项卡上。idQ 需要命名空间声明(请参阅 配置 customUI 元素)。

insertAfterMso, insertBeforeMso

将自定义选项卡插入到内置选项卡之后或之前。

insertAfterQ, insertBeforeQ

将自定义选项卡插入到另一个自定义选项卡之后或之前。需要命名空间声明(请参阅 配置 customUI 元素)。

label

指定自定义选项卡的 UI 标签。

如果未为 tab 元素指定 id、idMso 或 idQ 属性,则 thinkcell 组会显示在 Insert 选项卡上。

示例

本示例中的参数将配置以下内容:

  • 将 thinkcell 组插入到新选项卡上。
  • 将该选项卡标记为 My New Tab。
  • 将新选项卡插入到内置 Home 选项卡之后。

组策略

若要使用 组策略 配置此示例,请在组策略设置 PowerPoint Ribbon 中的 <tab 内输入 id="TabNew" label="My New Tab" insertAfterMso="TabHome"。

安装命令行

若要使用安装命令行参数(请参阅 在 Windows 上安装)配置此示例,请使用以下命令行参数运行 thinkcell 安装文件:

RIBBONPPTABINSERT="id=""TabNew"" label=""My New Tab"" insertAfterMso=""TabHome"""

配置 group 元素

若要配置 thinkcell 组的 group 元素,请使用以下配置参数。

Group policy 选项

命令行参数

可能的属性

说明

PowerPoint:
PowerPoint Ribbon > <group

Excel:
Excel Ribbon > <group

PowerPoint:
RIBBONPPGROUPINSERT

Excel:
RIBBONXLGROUPINSERT

id, idQ

指定 thinkcell 组的标识符。idQ 需要命名空间声明(请参阅 配置 customUI 元素)。

insertAfterMso, insertBeforeMso

将 thinkcell 组插入到内置组之后或之前。

insertAfterQ, insertBeforeQ

将 thinkcell 组插入到自定义组之后或之前。需要命名空间声明(请参阅 配置 customUI 元素)。

label

指定 thinkcell 组的 UI 标签

如果未为 group 元素指定 id 或 idQ 属性,thinkcell 会自动为 thinkcell 组生成唯一标识符(id)。如果未指定 label 属性,该组的 UI 标签为 thinkcell。

示例

本示例中的参数将配置以下内容:

  • 将 thinkcell 组插入到 PowerPoint Home 选项卡上。
  • 将 thinkcell 组插入到 Font 组之后。
  • 将 thinkcell 组的 UI 标签更改为 My New Group。

组策略

若要使用 组策略 配置此示例,请在组策略设置 PowerPoint Ribbon 中输入以下内容:

  • 在 <tab 中,输入 idMso="TabHome"。
  • 在 <group 中,输入 insertAfterMso="GroupFont" label="My New Group"。

安装命令行

若要使用安装命令行参数(请参阅 在 Windows 上安装)配置此示例,请使用以下命令行参数运行 thinkcell 安装文件:

RIBBONPPTABINSERT="idMso=""TabHome""" RIBBONPPGROUPINSERT="insertAfterMso=""GroupFont"" label=""My New Group"""

配置 customUI 元素

若要使用 idQ、insertAfterQ 和 insertbeforeQ 属性,必须为 customUI 元素声明 XML 命名空间(请参阅 使用 idQ 和 xmlns 定位自定义控件)。若要声明命名空间,请在组策略设置 PowerPoint Ribbon 或 Excel Ribbon 的 <customUI 选项中,或使用命令行参数RIBBONPPXMLNS 或 RIBBONXLXMLNS,指定以下值:

xmlns:<var>NAMESPACE_ID</var>="<var>NAMESPACE_URI</var>"

替换以下内容:

  • NAMESPACE_ID:命名空间标识符,例如 ex
  • NAMESPACE_URI:命名空间 URI,例如 http://schemas.example.com/customribbon
示例

本示例中的参数将配置以下内容:

  • 声明一个 XML 命名空间,其命名空间标识符为 ex。
  • 为标记为 My New Tab 的自定义选项卡指定 idQ。
  • 将 My New Tab 插入到内置 Insert 选项卡之后。
  • 为 thinkcell 组指定 idQ。
  • 将 thinkcell 组插入到自定义组 ex:GroupCustom 之后。

组策略

若要使用 组策略 配置此示例,请在组策略设置 PowerPoint Ribbon 中输入以下内容:

  • 在 <customUI 中,输入 xmlns:ex="http://schemas.example.com/customribbon"。
  • 在 <tab 中,输入 idQ="ex:TabNew" label="My New Tab" insertAfterMso="TabInsert"。
  • 在 <group 中,输入 idQ="ex:GroupThinkCell" insertAfterQ="ex:GroupCustom"。

安装命令行

若要使用安装命令行参数(请参阅 在 Windows 上安装)配置此示例,请使用以下命令行参数运行 thinkcell 安装文件:

RIBBONPPXMLNS="xmlns:ex=""http://schemas.example.com/customribbon""" RIBBONPPTABINSERT="idQ=""ex:TabNew"" label=""My New Tab"" insertAfterMso=""TabInsert""" RIBBONPPGROUPINSERT="idQ=""ex:GroupThinkCell"" insertAfterQ=""ex:GroupCustom"""

配置第二个 thinkcell 组

在 PowerPoint 中,当你将 thinkcell 组添加到 Home 选项卡时,可能还需要配置第二个 thinkcell 组。这是因为 PowerPoint 功能区在普通视图中有一个 Home 选项卡(TabHome),在幻灯片母版视图中也有一个 Home 选项卡(TabSlideMasterHome)。若要在两个视图的 Home 选项卡上都看到 thinkcell 组,请在这两个选项卡上都配置一个 thinkcell 组。

你也可以在 PowerPoint 或 Excel 中的任何选项卡上配置第二个 thinkcell 组。

若要配置第二个 thinkcell 组,请使用以下配置参数。

Group policy 选项

命令行参数

可能的属性

说明

PowerPoint:
PowerPoint Ribbon > <tab

Excel:
Excel Ribbon > <tab

PowerPoint:
RIBBONPPTABINSERT2

Excel:
RIBBONXLTABINSERT2

请参阅 配置 tab 元素。

请参阅 配置 tab 元素。

PowerPoint:
PowerPoint Ribbon > <group

Excel:
Excel Ribbon > <group

PowerPoint:
RIBBONPPGROUPINSERT2

Excel:
RIBBONXLGROUPINSERT2

请参阅 配置 group 元素。

请参阅 配置 group 元素。

使用 idQ 和 xmlns 定位自定义控件

你需要使用限定标识符(idQ)来在功能区上定位来自多个加载项的自定义控件。例如,若要将 thinkcell 选项卡定位在自定义选项卡之前或之后(请参阅 配置默认 thinkcell 选项卡的位置和标签),两个选项卡都应具有 idQ。

限定标识符由 XML 命名空间标识符和自定义选项卡、组或其他控件的唯一标识符组成。例如,限定标识符 ex:TabCustom 由 XML 命名空间 ex 和唯一标识符 TabCustom 组成。

若要使用限定标识符,必须声明 XML 命名空间。若要声明命名空间,请使用以下代码:

xmlns:<var>NAMESPACE_ID</var>="<var>NAMESPACE_URI</var>"

替换以下内容:

  • NAMESPACE_ID:命名空间标识符,例如 ex
  • NAMESPACE_URI:命名空间 URI,例如 http://schemas.example.com/customribbon

保留自定义控件的位置

如果多个加载项自定义功能区,自定义控件可能并不总是显示在相同位置。这是因为 PowerPoint 可能不会始终按相同顺序加载加载项。如果在 配置 customUI 元素 的示例中,PowerPoint 在创建 ex:GroupCustom 组的加载项之前加载 thinkcell 加载项,则 insertAfterQ="ex:GroupCustom" 将不起作用。若要确保来自多个加载项的自定义元素始终显示在功能区上的相同位置,当你相对于另一个自定义元素定位某个自定义元素时,请为两个元素都指定引用对方的位置属性。在 配置 customUI 元素 的示例中,请在 ex:GroupCustom 组的 XML 代码中指定 insertBeforeQ="ex:GroupThinkCell"。

需要排查问题吗?

查看我们的知识库