PowerPoint- und Excel-Menübänder konfigurieren

  1. Startseite
  2. Ressourcen
  3. Benutzerhandbuch
  4. Bereitstellungshandbuch
  5. PowerPoint- und Excel-Menübänder konfigurieren

thinkcell verfügt über viele Steuerelemente im Menüband, d. h. Registerkarten, Gruppen und Befehle, für PowerPoint und Excel. Beispielsweise enthalten die standardmäßigen thinkcell-Menüband-Registerkarten thinkcell-Steuerelemente und integrierte Office-Steuerelemente, die von links nach rechts so angeordnet sind, dass sie den Prozess der Erstellung einer Präsentation (PowerPoint) und der Arbeit mit Daten (Excel) widerspiegeln. Als Administrator können Sie thinkcell-Steuerelemente, integrierte Office-Steuerelemente und Steuerelemente anderer Add-ins im Menüband für Benutzer in Ihrer Organisation konfigurieren.

Unter Windows konfigurieren Sie das Menüband mit Gruppenrichtlinien (siehe Gruppenrichtlinien) oder während der Installation mit Befehlszeilenparametern (siehe Installation unter Windows).

Auf dem Mac konfigurieren Sie das Menüband mit dem Befehlszeilentool defaults (siehe Installation unter macOS) oder einer Geräteverwaltungslösung (siehe Verwaltete Bereitstellung unter macOS).

Menüband-Registerkarte mit einer .officeUI-Datei konfigurieren

Nur Windows

Unter Windows können Administratoren mit einer .officeUI-XML-Datei eine angepasste Menüband-Registerkarte in ihrer gesamten Organisation konfigurieren und bereitstellen. Als Administrator können Sie die thinkcell-Menüband-Registerkarte oder eine andere benutzerdefinierte Registerkarte mit einer beliebigen Kombination aus thinkcell-Steuerelementen, integrierten Office-Steuerelementen und Steuerelementen anderer Add-ins konfigurieren. Informationen zum Anpassen des Menübands als Standardbenutzer finden Sie unter thinkcell-Menüband-Steuerelemente anpassen.

thinkcell lädt Ihre .officeUI-Registerkartenkonfiguration jedes Mal, wenn PowerPoint oder Excel geöffnet wird. Im Allgemeinen lässt thinkcell die eigenen Menübandanpassungen der Benutzer, wie die Symbolleiste für den Schnellzugriff und zusätzliche Menüband-Registerkarten, unverändert. Wenn Sie jedoch die Registerkarte thinkcell konfigurieren und ein Benutzer die Registerkarte thinkcell in PowerPoint ebenfalls angepasst hat, überschreibt Ihre Konfiguration die Anpassung des Benutzers. Wenn ein Benutzer Tools Extras Menüsymbol > Restore thinkcell Tab auswählt, lädt thinkcell die in Ihrer XML-Datei angegebene angepasste Registerkarte und überschreibt alle widersprüchlichen Menübandanpassungen des Benutzers.

Die .officeUI-Registerkartenkonfiguration überschreibt die Positions- und Beschriftungskonfiguration der standardmäßigen thinkcell-Registerkarte (siehe Position und Beschriftung der standardmäßigen thinkcell -Registerkarten konfigurieren).

Um eine angepasste Registerkarte zu konfigurieren, gehen Sie wie folgt vor:

  1. XML-Datei für eine angepasste Registerkarte erstellen.
  2. Angepasste Registerkarte bereitstellen.

Wenn Sie dem Menüband mehr als eine angepasste Registerkarte hinzufügen möchten, wenden Sie sich bitte an unser Support-Team.

XML-Datei für eine angepasste Registerkarte erstellen

Um eine XML-Datei zu erstellen, die Ihre angepasste Registerkarte codiert, gehen Sie wie folgt vor:

  1. Öffnen Sie bei installiertem thinkcell die App, in der Sie eine Registerkarte anpassen möchten, also PowerPoint oder Excel.
  2. Klicken Sie mit der rechten Maustaste auf das Menüband und wählen Sie Customize the Ribbon aus.
  3. Passen Sie in Customize the Ribbon die Registerkarte thinkcell an oder erstellen Sie eine neue benutzerdefinierte Registerkarte. Sie finden die Registerkarte thinkcell in der Liste Customize the Ribbon als thinkcell (Custom). Um eine neue benutzerdefinierte Registerkarte zu erstellen, wählen Sie New Tab aus.

    Ihre Registerkarte kann eine beliebige Kombination aus thinkcell-Steuerelementen, integrierten Office-Steuerelementen und Steuerelementen anderer Add-ins enthalten. Um alle thinkcell-Menübandbefehle anzuzeigen, öffnen Sie das Dropdown-Menü Choose commands from und wählen Sie Main Tabs aus. Öffnen Sie in der Liste Choose commands from unter Main Tabs thinkcell Commands > thinkcell Commands.

    Sie können die Position Ihrer Registerkarte im Menüband, die UI-Beschriftung und die Steuerelemente anpassen. Weitere Informationen finden Sie beim Microsoft-Support.

    Wenn Sie fertig sind, wählen Sie OK aus.

  4. Schließen Sie die App.
  5. Wechseln Sie im Datei-Explorer zu %AppData% oder %LocalAppData%, je nachdem, ob Office-Benutzeranpassungen servergespeichert bzw. lokal sind. Kopieren Sie im Unterordner Microsoft\Office die .officeUI-Datei der Anwendung mit der angepassten Registerkarte, also PowerPoint.officeUI oder Excel.officeUI. Wir empfehlen, die kopierte Datei umzubenennen, beispielsweise in think-cell.officeUI.

Wenn Sie die .officeUI-Datei selbst schreiben, stellen Sie Folgendes sicher:

  • Die Datei liegt im standardmäßigen Custom UI XML-Format vor (siehe Microsoft Learn).
  • Die ID der angepassten Registerkarte lautet ThinkCellTab0.

Angepasste Registerkarte bereitstellen

Nachdem Sie eine .officeUI-XML-Datei erstellt haben, die Ihre angepasste Registerkarte codiert, stellen Sie die Datei für alle Benutzer unter demselben Pfad bereit, beispielsweise C:\Program Files (x86)\think-cell\customizations\think-cell.officeUI. Um die angepasste Registerkarte zu laden, müssen Benutzer in Ihrer Organisation immer dann Zugriff auf die XML-Datei haben, wenn sie PowerPoint oder Excel öffnen.

Geben Sie anschließend mithilfe von Gruppenrichtlinien oder Installations-Befehlszeilenparametern den Pfad zur XML-Datei an. Der Pfad kann ein relativer Pfad vom thinkcell-Installationsordner aus oder ein absoluter Pfad sein.

Gruppenrichtlinien

Um Ihre angepasste Registerkarte mit Gruppenrichtlinien bereitzustellen, gehen Sie wie folgt vor:

  1. Öffnen Sie die Einstellung thinkcell Tab für die App, die Sie konfigurieren möchten, also PowerPoint thinkcell Tab oder Excel thinkcell Tab.
  2. Wählen Sie Enabled aus.
  3. Geben Sie in File path den Pfad der .officeUI-Datei ein, beispielsweise customizations\think-cell.officeUI. Schließen Sie den Pfad nicht in Anführungszeichen ein.
  4. Wählen Sie OK aus.

Um die angepasste Registerkarte zu entfernen, wählen Sie Not Configured und anschließend OK aus.

Installationsbefehlszeile

Um Ihre angepasste Registerkarte mit Installationsbefehlszeilenparametern bereitzustellen (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit dem Parameter RIBBONPPCUSTOMTHINKCELLTAB (PowerPoint) oder RIBBONXLCUSTOMTHINKCELLTAB (Excel) aus. Legen Sie den Parameter auf den Pfad der .officeUI-Datei fest.

Wenn Sie beispielsweise Ihre angepasste Registerkarte in PowerPoint mithilfe einer XML-Datei customizations\think-cell.officeUI im thinkcell-Installationsordner bereitstellen möchten, verwenden Sie den folgenden Befehlszeilenparameter:

RIBBONPPCUSTOMTHINKCELLTAB=customizations\think-cell.officeUI

Um die angepasste Registerkarte zu entfernen, führen Sie die thinkcell-Installationsdatei aus und legen Sie den Parameter auf "" fest. Um die Registerkarte beispielsweise aus PowerPoint zu entfernen, verwenden Sie den folgenden Parameter:

RIBBONPPCUSTOMTHINKCELLTAB=""

Position und Beschriftung der standardmäßigen thinkcell-Registerkarten konfigurieren

Nur Windows

Unter Windows können Sie als Administrator die Menübandposition und die UI-Beschriftung der thinkcell-Registerkarten in PowerPoint und Excel konfigurieren. Geben Sie dazu in den thinkcell-Konfigurationsparametern XML-Attribute an, die die gewünschte Konfiguration codieren.

Wenn Sie auch angepasste Menüband-Registerkarten konfigurieren (siehe Menüband-Registerkarte mit einer .officeUI-Datei konfigurieren), überschreiben die angepassten Registerkarten die Konfiguration der thinkcell-Registerkarte.

Um die Position und Beschriftung der standardmäßigen thinkcell-Registerkarte festzulegen, verwenden Sie die Konfigurationsparameter in der folgenden Tabelle. Nachdem Sie die Konfigurationsparameter angegeben haben, öffnen Sie PowerPoint oder Excel und wählen Sie Tools Extras Menüsymbol > Restore thinkcell Tab , um das Menüband mit Ihren Änderungen zu aktualisieren.

Wenn Sie Befehlszeilenparameter angeben, schließen Sie XML-Code in Anführungszeichen (" ") und Attributwerte in zwei Sätze von Anführungszeichen ("" "") ein. Geben Sie beispielsweise in der Befehlszeile den XML-Code insertAfterMso="TabHome" als "insertAfterMso=""TabHome""" ein.

Group policy-Optionen

Befehlszeilenparameter

Mögliche Attribute

Beschreibung

PowerPoint:
PowerPoint thinkcell Tab > <tab

Excel:
Excel thinkcell Tab > <tab

PowerPoint:
RIBBONPPTHINKCELLTABINSERT


Excel:
RIBBONXLTHINKCELLTABINSERT

insertAfterMso, insertBeforeMso

Fügt die thinkcell-Registerkarte nach oder vor einer integrierten Registerkarte ein.

insertAfterQ, insertBeforeQ

Fügt die thinkcell-Registerkarte nach oder vor einer anderen benutzerdefinierten Registerkarte ein. Erfordert eine XML-Namespace-Deklaration (siehe Benutzerdefinierte Steuerelemente mit idQ und xmlns positionieren).

label

Legt die UI-Beschriftung für die thinkcell-Registerkarte fest.

xmlns:NS_ID

Ersetzen Sie NS_ID durch den Namespace-Bezeichner.

Deklariert einen XML-Namespace für eine benutzerdefinierte Registerkarte (siehe Benutzerdefinierte Steuerelemente mit idQ und xmlns positionieren).

Beispiel

Die Parameter in diesem Beispiel konfigurieren Folgendes:

  • Die standardmäßige thinkcell-Registerkarte im PowerPoint-Menüband nach der Registerkarte Home einfügen.
  • Die Beschriftung der standardmäßigen thinkcell-Registerkarte in My New Tab ändern.

Gruppenrichtlinien

Um dieses Beispiel mithilfe von Gruppenrichtlinien zu konfigurieren, gehen Sie wie folgt vor:

  1. Öffnen Sie die Gruppenrichtlinieneinstellung PowerPoint thinkcell Tab.
  2. Wählen Sie Enabled.
  3. Geben Sie in <tab insertAfterMso="TabHome" label="My New Tab" ein.
  4. Wählen Sie OK.
  5. Wählen Sie in PowerPoint auf der Registerkarte Insert die Option Tools Extras Menüsymbol > Reset thinkcell Tab .

Um die standardmäßige thinkcell-Registerkarte wiederherzustellen, gehen Sie wie folgt vor:

  1. Wählen Sie in der Gruppenrichtlinieneinstellung PowerPoint thinkcell Tab die Option Not Configured.
  2. Wählen Sie in PowerPoint auf der Registerkarte Insert die Option Tools Extras Menüsymbol > Reset thinkcell Tab .

Installationsbefehlszeile

Um dieses Beispiel mithilfe von Installationsbefehlszeilenparametern zu konfigurieren (siehe Installation unter Windows), gehen Sie wie folgt vor:

  1. Führen Sie die thinkcell-Installationsdatei mit dem folgenden Parameter aus:
RIBBONPPTHINKCELLTABINSERT="insertAfterMso=""TabHome"" label=""My New Tab"""
  1. Wählen Sie in PowerPoint auf der Registerkarte Insert die Option Tools Extras Menüsymbol > Reset thinkcell Tab .

Um die standardmäßige thinkcell-Registerkarte wiederherzustellen, gehen Sie wie folgt vor:

  1. Führen Sie die thinkcell-Installationsdatei mit dem folgenden Parameter aus:
RIBBONPPTHINKCELLTABINSERT=""
  1. Wählen Sie in PowerPoint auf der Registerkarte Insert die Option Tools Extras Menüsymbol > Reset thinkcell Tab .

thinkcell-Registerkarten aktivieren oder deaktivieren

Als Administrator können Sie die thinkcell-Registerkarten in PowerPoint und Excel aktivieren oder deaktivieren. Wenn Sie die thinkcell-Registerkarte deaktivieren, blendet thinkcell außerdem Reset thinkcell Tab (Windows) und Show thinkcell Tab (macOS) im Menü Tools Extras Menüsymbol aus.

Um die thinkcell-Registerkarte zu aktivieren oder zu deaktivieren, verwenden Sie die folgenden Konfigurationsparameter.

Windows

thinkcell-Registerkarte deaktivieren

Um die thinkcell-Registerkarte unter Windows zu deaktivieren, gehen Sie wie folgt vor:

  1. Laden der thinkcell-Registerkarte deaktivieren.
  2. thinkcell-Registerkarte im Menüband entfernen.
1. Laden der thinkcell-Registerkarte deaktivieren

Sie können das Laden der thinkcell-Registerkarte mithilfe von Gruppenrichtlinien oder Installationsbefehlszeilenparametern deaktivieren.

Um das Laden der thinkcell-Registerkarte mithilfe von Gruppenrichtlinien zu deaktivieren, gehen Sie wie folgt vor:

  1. Öffnen Sie die Einstellung der thinkcell-Registerkarte für die App, die Sie konfigurieren möchten, also PowerPoint thinkcell Tab oder Excel thinkcell Tab.
  2. Wählen Sie Disabled.
  3. Wählen Sie OK.

Um das Laden der thinkcell-Registerkarte mithilfe von Installationsbefehlszeilenparametern zu deaktivieren (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit dem entsprechenden Parameter aus:

  • Um die PowerPoint-thinkcell-Registerkarte zu deaktivieren: RIBBONPPNOTHINKCELLTAB=1
  • Um die Excel-thinkcell-Registerkarte zu deaktivieren: RIBBONXLNOTHINKCELLTAB=1
2. thinkcell-Registerkarte im Menüband entfernen

Um die thinkcell-Registerkarte im Menüband zu entfernen, gehen Sie wie folgt vor:

  1. Öffnen Sie die App, deren thinkcell-Registerkarte Sie deaktivieren möchten, also PowerPoint oder Excel.
  2. Klicken Sie mit der rechten Maustaste auf einen leeren Bereich im Menüband. Wählen Sie Customize the Ribbon.
  3. Entfernen Sie unter Customize the Ribbon die Registerkarte thinkcell (Custom). Weitere Informationen finden Sie unter Microsoft Learn.
  4. Schließen Sie die App.

thinkcell-Registerkarte aktivieren

Um die thinkcell-Registerkarte unter Windows zu aktivieren, gehen Sie wie folgt vor:

  1. Laden der thinkcell-Registerkarte aktivieren.
  2. thinkcell-Registerkarte zurücksetzen.
1. Laden der thinkcell-Registerkarte aktivieren

Sie können das Laden der thinkcell-Registerkarte mithilfe von Gruppenrichtlinien oder Installationsbefehlszeilenparametern aktivieren.

Um das Laden der thinkcell-Registerkarte mithilfe von Gruppenrichtlinien zu aktivieren, gehen Sie wie folgt vor:

  1. Öffnen Sie die Einstellung der thinkcell-Registerkarte für die App, die Sie konfigurieren möchten, also PowerPoint thinkcell Tab oder Excel thinkcell Tab.
  2. Wählen Sie Not Configured oder Enabled.
  3. Wählen Sie OK.

Um das Laden der thinkcell-Registerkarte mithilfe von Installationsbefehlszeilenparametern zu aktivieren (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit dem entsprechenden Parameter aus:

  • Um die PowerPoint-thinkcell-Registerkarte zu aktivieren: RIBBONPPNOTHINKCELLTAB=0
  • Um die Excel-thinkcell-Registerkarte zu aktivieren: RIBBONXLNOTHINKCELLTAB=0
2. thinkcell-Registerkarte zurücksetzen

Um die thinkcell-Registerkarte zurückzusetzen, gehen Sie wie folgt vor:

  1. Öffnen Sie die App, deren thinkcell-Registerkarte Sie aktivieren möchten, also PowerPoint oder Excel.
  2. Gehen Sie im Menüband zu Insert > thinkcell > Tools Extras Menüsymbol . Wählen Sie Reset thinkcell Tab .
macOS

Um die thinkcell-Registerkarte auf dem Mac zu deaktivieren, legen Sie im Dictionary com.think-cell.settings.ribbonpp oder com.think-cell.settings.ribbonxl den booleschen Wert von NoThinkCellTab auf true fest.

Um beispielsweise die Registerkarte thinkcell in PowerPoint mit dem Tool defaults zu deaktivieren (siehe Installation unter macOS), verwenden Sie den folgenden Befehl:

sudo defaults write /Library/Preferences/com.microsoft.office.plist com.think-cell.settings.ribbonpp -dict-add NoThinkCellTab -bool true

Um dasselbe mit einer .plist-Datei für eine Geräteverwaltungslösung zu erreichen (siehe Verwaltete Bereitstellung unter macOS), verwenden Sie den folgenden Code:

<dict>
	<key>com.think-cell.settings.ribbonpp</key>
	<dict>
		<key>NoThinkCellTab</key>
		<true/>
	</dict>
</dict>

Um die Registerkarte thinkcell zu aktivieren, setzen Sie den booleschen Wert von NoThinkCellTab auf false.

thinkcell-Befehle nur in einer Gruppe thinkcell anzeigen

Nur Windows

In PowerPoint fügt thinkcell Befehle zu vielen Menüband-Registerkarten und -Gruppen hinzu. Als Administrator können Sie thinkcell-Befehle auf integrierten Menüband-Registerkarten auf eine einzelne Gruppe thinkcell auf der Registerkarte Insert beschränken. Dieser Konfigurationsparameter wirkt sich nicht auf die Registerkarte thinkcell aus.

Gruppenrichtlinien

Um thinkcell-Befehle mit Gruppenrichtlinien auf die Gruppe thinkcell zu beschränken, gehen Sie wie folgt vor:

  1. Öffnen Sie die Gruppenrichtlinieneinstellung PowerPoint Ribbon.
  2. Wählen Sie Enabled.
  3. Wählen Sie Do Not Touch Built-In Ribbon.
  4. Wählen Sie OK.

Um thinkcell-Befehle auf anderen Menüband-Registerkarten und in anderen Gruppen wiederherzustellen, heben Sie die Auswahl von Do Not Touch Built-In Ribbon auf. Wählen Sie anschließend OK.

Installationsbefehlszeile

Um thinkcell-Befehle mit Installationsbefehlszeilenparametern auf die Gruppe thinkcell zu beschränken (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit dem Parameter RIBBONPPDONOTTOUCHBUILTINRIBBON=1 aus.

Um thinkcell-Befehle auf anderen Menüband-Registerkarten und in anderen Gruppen wiederherzustellen, führen Sie die thinkcell-Installationsdatei mit dem Parameter RIBBONPPDONOTTOUCHBUILTINRIBBON=0 aus.

Gruppe thinkcell konfigurieren

Nur Windows

Als Administrator können Sie festlegen, auf welcher integrierten oder benutzerdefinierten Menüband-Registerkarte die Gruppe thinkcell angezeigt wird, an welcher Position sie sich auf einer Registerkarte befindet und welche UI-Bezeichnung sie hat.

Wenn Sie Befehlszeilenparameter angeben, schließen Sie XML-Code in Anführungszeichen (" ") und Attributwerte in zwei Paare von Anführungszeichen ("" "") ein. Geben Sie beispielsweise in der Befehlszeile den XML-Code idMso="TabHome" als "idMso=""TabHome""" ein.

Weitere Informationen zur Konfiguration des Office-Menübands finden Sie unter Microsoft Learn.

Element tab konfigurieren

Um das Element tab zu konfigurieren, in dem die Gruppe thinkcell angezeigt wird, verwenden Sie die folgenden Konfigurationsparameter.

Group policy -Optionen

Befehlszeilenparameter

Mögliche Attribute

Beschreibung

PowerPoint:
PowerPoint Ribbon > <tab

Excel:
Excel Ribbon > <tab

PowerPoint:
RIBBONPPTABINSERT

Excel:
RIBBONXLTABINSERT

idMso

Fügt die Gruppe thinkcell auf einer integrierten Registerkarte ein.

id, idQ

Fügt die Gruppe thinkcell auf einer benutzerdefinierten Registerkarte ein. idQ erfordert eine Namespace-Deklaration (siehe Element customUI konfigurieren).

insertAfterMso, insertBeforeMso

Fügt die benutzerdefinierte Registerkarte nach oder vor einer integrierten Registerkarte ein.

insertAfterQ, insertBeforeQ

Fügt die benutzerdefinierte Registerkarte nach oder vor einer anderen benutzerdefinierten Registerkarte ein. Erfordert eine Namespace-Deklaration (siehe Element customUI konfigurieren).

label

Gibt die UI-Bezeichnung für die benutzerdefinierte Registerkarte an.

Wenn Sie für das Element tab kein Attribut id, idMso oder idQ angeben, wird die Gruppe thinkcell auf der Registerkarte Insert angezeigt.

Beispiel

Die Parameter in diesem Beispiel konfigurieren Folgendes:

  • Fügen Sie die Gruppe thinkcell auf einer neuen Registerkarte ein.
  • Benennen Sie die Registerkarte My New Tab.
  • Fügen Sie die neue Registerkarte nach der integrierten Registerkarte Home ein.

Gruppenrichtlinien

Um dieses Beispiel mit Gruppenrichtlinien zu konfigurieren, geben Sie in der Gruppenrichtlinieneinstellung PowerPoint Ribbon unter <tab Folgendes ein: id="TabNew" label="My New Tab" insertAfterMso="TabHome".

Installationsbefehlszeile

Um dieses Beispiel mit Installationsbefehlszeilenparametern zu konfigurieren (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit dem folgenden Befehlszeilenparameter aus:

RIBBONPPTABINSERT="id=""TabNew"" label=""My New Tab"" insertAfterMso=""TabHome"""

Element group konfigurieren

Um das Element group für die Gruppe thinkcell zu konfigurieren, verwenden Sie die folgenden Konfigurationsparameter.

Group policy -Optionen

Befehlszeilenparameter

Mögliche Attribute

Beschreibung

PowerPoint:
PowerPoint Ribbon > <group

Excel:
Excel Ribbon > <group

PowerPoint:
RIBBONPPGROUPINSERT

Excel:
RIBBONXLGROUPINSERT

id, idQ

Gibt den Bezeichner für die Gruppe thinkcell an. idQ erfordert eine Namespace-Deklaration (siehe Element customUI konfigurieren).

insertAfterMso, insertBeforeMso

Fügt die Gruppe thinkcell nach oder vor einer integrierten Gruppe ein.

insertAfterQ, insertBeforeQ

Fügt die Gruppe thinkcell nach oder vor einer benutzerdefinierten Gruppe ein. Erfordert eine Namespace-Deklaration (siehe Element customUI konfigurieren).

label

Gibt die UI-Bezeichnung für die Gruppe thinkcell an

Wenn Sie für das Element group kein Attribut id oder idQ angeben, generiert thinkcell automatisch einen eindeutigen Bezeichner (id) für die Gruppe thinkcell. Wenn Sie kein Attribut label angeben, lautet die UI-Bezeichnung der Gruppe thinkcell.

Beispiel

Die Parameter in diesem Beispiel konfigurieren Folgendes:

  • Fügen Sie die Gruppe thinkcell auf der PowerPoint-Registerkarte Home ein.
  • Fügen Sie die Gruppe thinkcell nach der Gruppe Font ein.
  • Ändern Sie die UI-Bezeichnung der Gruppe thinkcell in My New Group.

Gruppenrichtlinien

Um dieses Beispiel mit Gruppenrichtlinien zu konfigurieren, geben Sie in der Gruppenrichtlinieneinstellung PowerPoint Ribbon Folgendes ein:

  • Geben Sie unter <tab Folgendes ein: idMso="TabHome".
  • Geben Sie unter <group Folgendes ein: insertAfterMso="GroupFont" label="My New Group".

Installationsbefehlszeile

Um dieses Beispiel mit Installationsbefehlszeilenparametern zu konfigurieren (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit den folgenden Befehlszeilenparametern aus:

RIBBONPPTABINSERT="idMso=""TabHome""" RIBBONPPGROUPINSERT="insertAfterMso=""GroupFont"" label=""My New Group"""

Element customUI konfigurieren

Um die Attribute idQ, insertAfterQ und insertbeforeQ zu verwenden, müssen Sie einen XML-Namespace für das Element customUI deklarieren (siehe Benutzerdefinierte Steuerelemente mit idQ und xmlns positionieren). Um einen Namespace zu deklarieren, geben Sie in den Gruppenrichtlinieneinstellungen PowerPoint Ribbon oder Excel Ribbon in der Option <customUI oder über die BefehlszeilenparameterRIBBONPPXMLNS oder RIBBONXLXMLNS den folgenden Wert an:

xmlns:<var>NAMESPACE_ID</var>="<var>NAMESPACE_URI</var>"

Ersetzen Sie Folgendes:

  • NAMESPACE_ID: der Namespace-Bezeichner, z. B. ex
  • NAMESPACE_URI: der Namespace-URI, z. B. http://schemas.example.com/customribbon
Beispiel

Die Parameter in diesem Beispiel konfigurieren Folgendes:

  • Deklarieren Sie einen XML-Namespace mit dem Namespace-Bezeichner ex.
  • Geben Sie eine idQ für eine benutzerdefinierte Registerkarte mit der Bezeichnung My New Tab an.
  • Fügen Sie My New Tab nach der integrierten Registerkarte Insert ein.
  • Geben Sie eine idQ für die Gruppe thinkcell an.
  • Fügen Sie die Gruppe thinkcell nach der benutzerdefinierten Gruppe ex:GroupCustom ein.

Gruppenrichtlinien

Um dieses Beispiel mit Gruppenrichtlinien zu konfigurieren, geben Sie in der Gruppenrichtlinieneinstellung PowerPoint Ribbon Folgendes ein:

  • Geben Sie unter <customUI Folgendes ein: xmlns:ex="http://schemas.example.com/customribbon".
  • Geben Sie unter <tab Folgendes ein: idQ="ex:TabNew" label="My New Tab" insertAfterMso="TabInsert".
  • Geben Sie unter <group Folgendes ein: idQ="ex:GroupThinkCell" insertAfterQ="ex:GroupCustom".

Installationsbefehlszeile

Um dieses Beispiel mit Installationsbefehlszeilenparametern zu konfigurieren (siehe Installation unter Windows), führen Sie die thinkcell-Installationsdatei mit den folgenden Befehlszeilenparametern aus:

RIBBONPPXMLNS="xmlns:ex=""http://schemas.example.com/customribbon""" RIBBONPPTABINSERT="idQ=""ex:TabNew"" label=""My New Tab"" insertAfterMso=""TabInsert""" RIBBONPPGROUPINSERT="idQ=""ex:GroupThinkCell"" insertAfterQ=""ex:GroupCustom"""

Eine zweite Gruppe thinkcell konfigurieren

Wenn Sie in PowerPoint die Gruppe thinkcell zur Registerkarte Home hinzufügen, möchten Sie möglicherweise eine zweite Gruppe thinkcell konfigurieren. Der Grund dafür ist, dass das PowerPoint-Menüband eine Registerkarte Home in der Normalansicht (TabHome) und eine Registerkarte Home in der Folienmasteransicht (TabSlideMasterHome) hat. Um die Gruppe thinkcell auf der Registerkarte Home in beiden Ansichten zu sehen, konfigurieren Sie auf beiden Registerkarten eine Gruppe thinkcell.

Sie können eine zweite Gruppe thinkcell auch auf einer beliebigen Registerkarte in PowerPoint oder Excel konfigurieren.

Um eine zweite Gruppe thinkcell zu konfigurieren, verwenden Sie die folgenden Konfigurationsparameter.

Group policy-Optionen

Befehlszeilenparameter

Mögliche Attribute

Beschreibung

PowerPoint:
PowerPoint Ribbon > <tab

Excel:
Excel Ribbon > <tab

PowerPoint:
RIBBONPPTABINSERT2

Excel:
RIBBONXLTABINSERT2

Siehe Element tab konfigurieren.

Siehe Element tab konfigurieren.

PowerPoint:
PowerPoint Ribbon > <group

Excel:
Excel Ribbon > <group

PowerPoint:
RIBBONPPGROUPINSERT2

Excel:
RIBBONXLGROUPINSERT2

Siehe Element group konfigurieren.

Siehe Element group konfigurieren.

Benutzerdefinierte Steuerelemente mit idQ und xmlns positionieren

Sie benötigen qualifizierte Bezeichner (idQ), um benutzerdefinierte Steuerelemente aus mehreren Add-Ins im Menüband zu positionieren. Um beispielsweise die Registerkarte thinkcell vor oder nach einer benutzerdefinierten Registerkarte zu positionieren (siehe Position und Beschriftung der standardmäßigen thinkcell -Registerkarten konfigurieren), sollten beide Registerkarten eine idQ haben.

Ein qualifizierter Bezeichner besteht aus einem XML-Namespace-Bezeichner, gefolgt von einem eindeutigen Bezeichner für eine benutzerdefinierte Registerkarte, Gruppe oder ein anderes Steuerelement. Beispielsweise besteht der qualifizierte Bezeichner ex:TabCustom aus dem XML-Namespace ex und dem eindeutigen Bezeichner TabCustom.

Um qualifizierte Bezeichner zu verwenden, müssen Sie einen XML-Namespace deklarieren. Um einen Namespace zu deklarieren, verwenden Sie den folgenden Code:

xmlns:<var>NAMESPACE_ID</var>="<var>NAMESPACE_URI</var>"

Ersetzen Sie Folgendes:

  • NAMESPACE_ID: der Namespace-Bezeichner, z. B. ex
  • NAMESPACE_URI: der Namespace-URI, z. B. http://schemas.example.com/customribbon

Position benutzerdefinierter Steuerelemente beibehalten

Wenn mehrere Add-Ins das Menüband anpassen, werden benutzerdefinierte Steuerelemente möglicherweise nicht immer an derselben Position angezeigt. Das liegt daran, dass PowerPoint Add-Ins nicht immer in derselben Reihenfolge lädt. Wenn PowerPoint im Beispiel aus Element customUI konfigurieren das thinkcell-Add-In vor dem Add-In lädt, das die Gruppe ex:GroupCustom erstellt, hat insertAfterQ="ex:GroupCustom" keine Wirkung. Um sicherzustellen, dass benutzerdefinierte Elemente aus mehreren Add-Ins im Menüband immer an derselben Stelle angezeigt werden, geben Sie beim Positionieren eines benutzerdefinierten Elements relativ zu einem anderen benutzerdefinierten Element Positionsattribute für beide Elemente an, die auf das jeweils andere verweisen. Geben Sie im Beispiel aus Element customUI konfigurieren im XML-Code für die Gruppe ex:GroupCustom insertBeforeQ="ex:GroupThinkCell" an.

Brauchen Sie Hilfe bei der Fehlerbehebung?

Besuchen Sie unsere Knowledge Base