Erweiterte Berichtsautomatisierung
- Startseite
- Ressourcen
- Benutzerhandbuch
- thinkcell Charts: Datenvisualisierung
- Erweiterte Berichtsautomatisierung
Erweiterte Berichtsautomatisierung ist mit thinkcell Suite verfügbar.
Erstellen Sie automatisch Berichte und andere Präsentationen, die Sie regelmäßig aktualisieren. Die erweiterte Berichtsautomatisierung von thinkcell füllt PowerPoint-Vorlagen mit Ihren neuesten Excel- oder JSON-Daten.
Verwenden Sie bei der Excel-Datenautomatisierung die thinkcell-API, um thinkcell-Elemente in Ihrer Vorlage mit Daten aus Excel zu füllen. Weitere Informationen finden Sie unter Automatisierung mit Excel-Daten.
Verwenden Sie bei der JSON-Datenautomatisierung eine .ppttc-Datei, um thinkcell-Elemente in Ihrer Vorlage mit JSON-Daten zu füllen. Sie können lokal oder remote auf die JSON-Daten und PowerPoint-Vorlagen zugreifen und Präsentationen mit einem Webdienst erstellen. Weitere Informationen finden Sie unter Automatisierung mit JSON-Daten.
Diagrammanmerkungen werden automatisch zusammen mit Ihren Diagrammen aktualisiert. Wenn Sie Differenzpfeile, Trendlinien und andere Anmerkungen zu einem Diagramm in Ihrer Vorlage hinzufügen, spiegeln in der neuen Präsentation sowohl das Diagramm als auch die Anmerkungen die neuesten Daten wider.
Um die erweiterte Berichtsautomatisierung von thinkcell zu nutzen, benötigen Sie Folgendes:
- Eine PowerPoint-Präsentation mit thinkcell-Diagrammen oder anderen Elementen
- Programmlogik zum Füllen der Elemente mit Daten
PowerPoint-Vorlagen für die Berichtsautomatisierung erstellen
Um automatisch einen Bericht zu erstellen, benötigen Sie eine PowerPoint-Präsentation, die als Vorlage für Ihre neue Präsentation dient. Die Vorlage muss ein oder mehrere thinkcell-Elemente enthalten, die Sie mit Daten füllen möchten.
Wenn Sie die Excel-Automatisierungs-API PresentationFromTemplate verwenden, müssen die Elemente, die Sie mit Daten füllen möchten, mit Excel verknüpft sein (siehe Excel-Datenverknüpfungen).
Wenn Sie die JSON-Datenautomatisierung oder die Excel-Automatisierungs-API UpdateBatch verwenden, müssen die Elemente, die Sie mit Daten füllen möchten, Namen haben. Um ein Element zu benennen, gehen Sie wie folgt vor:
- Um ein thinkcell-Diagramm, eine Tabelle, einen Harvey Ball oder ein Kontrollkästchen zu benennen, wählen Sie das Element aus, um die Minisymbolleiste zu öffnen. Geben Sie in AddRangeData Name einen eindeutigen Namen ein, und wählen Sie Enter.
-
Um ein Automatisierungstextfeld zu benennen, führen Sie die folgenden Schritte aus:
- Fügen Sie das Objekt ein, in dem Sie das Automatisierungstextfeld platzieren möchten. Das Objekt kann ein thinkcell-Textfeld, ein Fünfeck, ein Chevron, ein abgerundetes Rechteck oder eine PowerPoint-Form sein.
- Platzieren Sie im Objekt den Textcursor an der Stelle, an der Sie das Textfeld hinzufügen möchten.
- Wählen Sie auf der Insert-Menüband-Registerkarte Elements > Automation Text Field
.
- Wählen Sie das Automatisierungstextfeld aus, das durch zwei spitze Klammern (<>) dargestellt wird, um die Minisymbolleiste zu öffnen. Geben Sie in AddRangeData Name einen eindeutigen Namen ein, und wählen Sie Enter.
Sie können einem Objekt mehr als ein Automatisierungstextfeld hinzufügen. Ein Objekt kann sowohl Automatisierungstextfelder als auch normalen Text enthalten.
- Nur für die Excel-Automatisierung: Um ein Bild einer Tabelle zu benennen (siehe Bilder von Tabellen erstellen), wählen Sie die Tabelle aus, um die Minisymbolleiste zu öffnen. Geben Sie in AddRangeImage Name einen eindeutigen Namen ein, und wählen Sie Enter.
Beispiel für eine PowerPoint-Vorlage
Für die JSON-Datenautomatisierung und die Excel-Automatisierungs-API UpdateBatch erstellen Sie eine beispielhafte PowerPoint-Vorlage mit einem gestapelten Säulendiagramm und einem Folientitel wie folgt:
- Wechseln Sie in PowerPoint zur Registerkarte Home. Wählen Sie in der Gruppe Slides die Option Layout > Title Only.
- Fügen Sie ein gestapeltes Säulendiagramm ein (siehe Einführung in Diagramme). Die Ausgangsdaten im Diagramm sind nicht wichtig, da Ihre Automatisierung die Daten in der Vorlage durch Excel- oder JSON-Daten ersetzt. Wenn Sie Position, Formatierung und Anmerkungen des Diagramms anpassen, erscheinen diese Anpassungen in Ihrer endgültigen Präsentation.
- Wählen Sie das Diagramm aus, um die Minisymbolleiste zu öffnen. Geben Sie in AddRangeData Name
Chart1ein. Wählen Sie Enter.
- Klicken Sie in den Platzhalter für den Folientitel, sodass der blinkende Textcursor angezeigt wird.
- Wählen Sie auf der Registerkarte Insert die Option Elements > Automation Text Field
.
- Wählen Sie das Automatisierungstextfeld aus, das durch zwei spitze Klammern (<>) dargestellt wird, um die Minisymbolleiste zu öffnen. Geben Sie in AddRangeData Name
SlideTitleein. Wählen Sie Enter.
- Speichern Sie die Präsentation als
template.pptx.
Erstellen Sie anschließend die Programmlogik, um Ihre Vorlage mit Daten zu füllen.
- Informationen zur Excel-Automatisierungs-API
UpdateBatchfinden Sie unter UpdateBatch. - Informationen zur JSON-Datenautomatisierung finden Sie unter Automatisierung mit JSON-Daten.
Wenn Sie mehr über die Erstellung automatisierter Dashboards speziell für Finanzplanung und -analyse erfahren möchten, lesen Sie diesen Blogartikel.
Brauchen Sie Hilfe bei der Fehlerbehebung?
Besuchen Sie unsere Knowledge Base