スライド ワークブック

スライド ワークブックは、PowerPoint スライドに組み込まれた、完全に機能する Excel ワークブックです。スライド ワークブックでは、次のことができます。

  • スライド上のすべての thinkcell グラフやその他の要素のデータを 1 か所で管理できます。
  • スライドに表示したくないコメントや計算を追加できます。
  • 同じデータ範囲からグラフと表を作成できます(グラフ データを表として複製する を参照)。
  • スライド ワークブックを Excel ファイルとしてコンピューターに保存できます。

スライド ワークブックを開く

スライド ワークブックを開くには、PowerPoint のリボンで Insert > thinkcell > Tools Tools Menu icon > Slide Workbook を選択します。スライド ワークブックは、スライドを編集している間、開いたままになります。ワークブックを閉じると、thinkcell が変更内容を自動的に保存します。

スライド ワークブック内の要素データの場所に移動するには、次のいずれかを実行します。

  • グラフ: グラフをダブルクリックします。または、グラフを選択してから Open Datasheet を選択します。
  • その他の要素: 要素を右クリックしてから Open Datasheet を選択します。

スライド上の要素とそのスライドのワークブックの間に Excel データ リンクを作成できます(Excel データ リンク を参照)。スライド ワークブックには、関連付けられたスライド上の要素へのリンクのみを含めることができます。

スライド ワークブックにリンクされている要素は、Data Links ダイアログには表示されません(Data Links ダイアログを使用してリンクデータを管理する を参照)。

要素をスライド ワークブックにリンクする方法は次のとおりです。

スライド ワークブックのデータから要素を作成する

スライド ワークブックにリンクされた要素をスライドに挿入するには、次の手順に従います。

  1. PowerPoint のリボンで Insert > thinkcell > Tools Tools Menu icon > Slide Workbook を選択します。
  2. スライド ワークブックで、要素のデータを入力します。グラフを作成する場合は、データがグラフのデータ レイアウトと一致していることを確認します。

    グラフのデータ レイアウトがわからない場合は、目的のグラフを挿入し、スライド ワークブックにリンクして(既存の要素をスライド ワークブックにリンクする を参照)、既定のデータを独自のデータに置き換えます。このセクションの残りの手順は省略してください。
  3. データを選択します。
  4. スライド ワークブックのリボンで、Insert タブの Link to PowerPoint メニューを開きます。次に、挿入する要素を選択します。
  5. スライド上で、要素を挿入する場所をクリックします。

既存の要素をスライド ワークブックにリンクするには、次の手順に従います。

  1. 要素が Excel ファイルにリンクされている場合は、まずリンクを削除します(データ リンクを削除する を参照)。
  2. 要素のデータシートを開きます(要素データシート を参照)。
  3. データシートのツールバーで Move Data to Slide Workbook を選択します。

要素をスライド ワークブックにリンクするたびに、thinkcell はワークブック内に新しいシートを作成し、そこにデータを挿入します。その後、データを切り取って別のシートに貼り付けても、貼り付けたデータは引き続き要素にリンクされたままになります。

要素データをスライド ワークブックから Excel ファイルに移動する

単一の要素のデータを Excel ファイルに移動することも、スライド ワークブック全体を Excel ファイルとして保存することもできます。

要素のデータを Excel ファイルに移動する

要素のリンクされたデータをスライド ワークブックから外部の Excel ファイルに移動するには、次の手順に従います。

  1. 要素の Excel リンクを削除します(データ リンクを削除する を参照)。
  2. データを Excel ファイルにコピーします。
  3. Excel ファイル内のデータを要素にリンクします(Excel データ リンク を参照)。

スライド ワークブックを Excel ファイルとして保存する

現在のスライド以外でスライド ワークブックを共有して使用するには、スライド ワークブックを Excel ファイルとして保存します。Excel ファイル内のデータは要素にリンクされません。

スライド ワークブックを Excel ファイルとして保存するには、スライド ワークブックのツールバーで File > Save As を選択します。ファイルに名前を付け、保存先を選択します。詳細については、ワークブックを保存するを参照してください。

スライド ワークブックを削除する

プレゼンテーションから 1 つまたは複数のスライド ワークブックを削除できます。要素データを Excel ファイルに移動した後、またはプレゼンテーションを共有する前に、スライド ワークブックを削除したい場合があります。

スライド ワークブックを削除すると、ワークブック内の要素データとその書式設定は、要素のデータシートに移動します。これは、表の画像(表の画像を作成する を参照)を除くすべての要素に適用されます。表の画像は、スライド ワークブックを削除するとデータが失われます。

プレゼンテーションからスライド ワークブックを削除する方法については、クリーンアップとサニタイズ を参照してください。

スライドを送信または保存する際にスライド ワークブックを削除する方法については、スライドの送信と保存を参照してください。


スライド ワークブックを使用してデータ量の多いプレゼンテーションを作成する方法については、こちらのブログ記事をご覧ください。

トラブルシューティングが必要ですか?

ナレッジベースをご確認ください