Collegamenti dati Excel
- Home
- Risorse
- Manuale dell’utente
- thinkcell Charts: visualizzazione dei dati
- Collegamenti dati esterni
- Collegamenti dati Excel
I collegamenti dati Excel sono disponibili con thinkcell Suite.
Usare i dati Excel nella presentazione collegando elementi esistenti a Excel o creando nuovi elementi direttamente da Excel. Quando i dati in Excel cambiano, gli elementi collegati restano aggiornati senza dover copiare e incollare manualmente i valori da Excel.
Questa pagina spiega come creare collegamenti dati tra Excel e PowerPoint e come gestire gli intervalli Excel collegati e adattarli alle esigenze della presentazione. Per sapere come gestire gli elementi collegati e aggiornare i relativi dati, vedere Gestire i dati negli elementi collegati.
Collegare gli elementi della presentazione a Excel
Usare i dati di Excel negli elementi thinkcell e nel testo della presentazione nelle diapositive. Quando si collega un elemento a un intervallo di Excel, i dati nelle celle collegate sostituiscono i dati corrispondenti nell'elemento.
È possibile Formattare e applicare stili agli elementi collegati a Excel come qualsiasi altro elemento thinkcell, oppure Abbinare la formattazione dell'elemento all'intervallo di dati collegato per controllare l'aspetto degli elementi collegati da Excel.
Collegare grafici e altri elementi a Excel
Usare i dati di Excel in grafici, tabelle, Harvey ball e caselle di controllo thinkcell nella presentazione. A tale scopo, seguire questi passaggi:
- In Excel, selezionare le celle che contengono i dati da usare nell'elemento.
- Sulla barra multifunzione, selezionare Insert > thinkcell > Link To PowerPoint > To Existing Element
. PowerPoint si apre.
- In PowerPoint, selezionare l'elemento.
In alternativa, seguire questi passaggi:
- In Excel, selezionare le celle che contengono i dati da usare nell'elemento.
- In PowerPoint, eseguire una delle operazioni seguenti:
- Selezionare l'elemento, quindi, sulla barra multifunzione, selezionare Insert > thinkcell Data > New Excel Link.
- Fare clic con il pulsante destro del mouse sull'elemento per aprire il relativo menu di scelta rapida, quindi selezionare Establish Excel Link
.
Se i layout dei dati degli intervalli di Excel e dei grafici e delle tabelle nella presentazione non corrispondono, è possibile Regolare gli intervalli collegati per far corrispondere i layout dei dati degli elementi senza modificare le singole celle.
Collegare il testo della presentazione a Excel
Collegare il testo in un oggetto thinkcell o PowerPoint a Excel e usare i dati Excel collegati per sostituire o integrare il testo. È possibile collegare a Excel il testo di qualsiasi oggetto nella presentazione, tranne le tabelle PowerPoint e gli elementi grafici SmartArt.
Per collegare il testo della presentazione a Excel, seguire questi passaggi:
- In Excel, selezionare la cella che contiene i dati da usare nell'oggetto.
- In PowerPoint, scegliere come usare i dati Excel collegati:
- Per sostituire il testo nell'oggetto con i dati Excel, selezionare l'oggetto.
- Per sostituire una parte del testo nell'oggetto con i dati Excel, selezionare il testo da sostituire.
- Per aggiungere i dati Excel senza sostituire il testo nell'oggetto, posizionare il cursore nel punto in cui si desidera visualizzare i dati Excel.
- In PowerPoint, sulla barra multifunzione, selezionare Insert > thinkcell > Elements > Text Linked to Excel
.
Creare nuovi elementi da Excel
Quando si desidera usare i dati Excel come punto di partenza per nuovi elementi, non è necessario creare gli elementi in PowerPoint e collegarli successivamente a Excel. È possibile creare grafici, tabelle, Harvey ball, caselle di controllo e immagini collegati nella presentazione direttamente da Excel.
È possibile Formattare e applicare stili agli elementi creati da Excel come qualsiasi altro elemento thinkcell, oppure Abbinare la formattazione dell'elemento all'intervallo di dati collegato per controllare l'aspetto degli elementi collegati da Excel.
Creare grafici da Excel
Per creare un grafico da Excel, seguire questi passaggi:
- In Excel, selezionare l'intervallo di celle da usare nella presentazione.
- Sulla barra multifunzione di Excel, selezionare Insert > thinkcell > Link To PowerPoint, quindi selezionare il tipo di grafico desiderato. PowerPoint si apre.
- In PowerPoint, posizionare il grafico in una diapositiva.
L'intervallo di Excel nell'esempio seguente corrisponde al layout predefinito per un grafico a colonne in pila: le righe sono serie e le colonne sono categorie.
Se il layout dei dati di un grafico e il relativo intervallo collegato non corrispondono, Regolare gli intervalli collegati per adattarlo al layout dei dati del grafico senza modificare le singole celle.
Creare tabelle da Excel
Esistono tre modi per ricreare le tabelle Excel come elementi thinkcell in PowerPoint:
Per aggiornare le tabelle o modificarne le impostazioni di aggiornamento, vedere Gestire i dati negli elementi collegati e Gestire i dati collegati con la finestra di dialogo Data Links. È possibile Formattare le tabelle create da Excel, ad eccezione delle immagini di tabelle, come qualsiasi altra tabella thinkcell.
Creare tabelle
Per creare una tabella thinkcell da Excel, seguire questi passaggi:
- In Excel, selezionare l'intervallo di celle da includere nella tabella.
- Nella scheda Insert, nel gruppo thinkcell, selezionare Link to PowerPoint > Table. PowerPoint si apre.
- In PowerPoint, posizionare la tabella in una diapositiva.
Creare tabelle con la formattazione di Excel
Creare una tabella in cui la maggior parte delle opzioni di formattazione, ad esempio stile del carattere, colore di riempimento e allineamento del testo, inizialmente corrisponde a quelle specificate nel foglio Excel. Per maggiori informazioni, vedere Abbinare la formattazione dell'elemento all'intervallo di dati collegato.
Per creare una tabella con la formattazione di Excel nella presentazione, seguire questi passaggi:
- In Excel, selezionare l'intervallo di celle da includere nella tabella.
- Nella scheda Insert, nel gruppo thinkcell, selezionare Link to PowerPoint > Table with Formatting. PowerPoint si apre.
- In PowerPoint, posizionare la tabella in una diapositiva.
Creare immagini di tabelle
Creare un'immagine di una tabella che corrisponda al foglio Excel. Aggiornare l'immagine da Excel come qualsiasi altro elemento collegato (vedere Gestire i dati negli elementi collegati). In PowerPoint, le immagini di tabelle si comportano come qualsiasi altra immagine. È possibile modificare il contenuto e la formattazione di un'immagine di una tabella solo usando il relativo foglio Excel collegato. Per inserire una tabella da Excel che è possibile modificare e formattare in PowerPoint, vedere Creare tabelle e Creare tabelle con la formattazione di Excel.
Per creare un'immagine di una tabella nella presentazione, seguire questi passaggi:
- In Excel, selezionare l'intervallo di celle da includere nella tabella.
- Nella scheda Insert, nel gruppo thinkcell, selezionare Link to PowerPoint > Table as Image. PowerPoint si apre.
- In PowerPoint, posizionare la tabella in una diapositiva.
Creare Harvey ball e caselle di controllo da Excel
Creare e controllare lo stato delle Harvey ball e delle caselle di controllo direttamente da una cartella di lavoro Excel. Per ulteriori informazioni su Harvey ball e caselle di controllo, vedere Harvey ball e caselle di controllo.
Creare Harvey ball da Excel
Per creare una Harvey ball da Excel, seguire questi passaggi:
- In Excel, in una cella vuota, specificare il numero di segmenti Harvey ball riempiti immettendo uno dei valori seguenti:
- Un numero assoluto compreso tra
0e4, che è il numero massimo predefinito di segmenti Harvey ball - Una percentuale compresa tra
0%e100% - Una formula che restituisce un numero assoluto compreso tra
0e4o una percentuale compresa tra0%e100%
- Un numero assoluto compreso tra
- Selezionare la cella, quindi selezionare Insert > thinkcell > Link to PowerPoint > Harvey Ball
. PowerPoint si apre.
- In PowerPoint, posizionare la Harvey ball in una diapositiva.
È possibile Modificare il numero di segmenti in una Harvey ball creata da Excel come in qualsiasi altra Harvey ball. Per modificare lo stato di completamento di una Harvey ball da Excel, nella cella collegata immettere un altro valore o un'altra formula. Per ulteriori informazioni sull'aggiornamento degli elementi collegati, vedere Gestire i dati negli elementi collegati.
Creare caselle di controllo da Excel
Per creare una casella di controllo da Excel, seguire questi passaggi:
- In una cella vuota, immettere un collegamento a un simbolo di casella di controllo o una formula che restituisca un collegamento:
- Casella di controllo vuota (☐):
0o uno spazio vuoto - Simbolo di spunta (✓):
1ov - Simbolo X (✗):
2ox - Simbolo di casella di controllo personalizzato: il collegamento al simbolo specificato nel file di stile thinkcell (vedere Personalizzare gli stili predefiniti delle caselle di controllo).
- Casella di controllo vuota (☐):
- Selezionare la cella, quindi selezionare Insert > thinkcell > Link to PowerPoint > Checkbox
. PowerPoint si apre.
- In PowerPoint, posizionare la casella di controllo in una diapositiva.
Per modificare il simbolo della casella di controllo da Excel, nella cella collegata immettere un altro collegamento al simbolo della casella di controllo o un'altra formula. Per ulteriori informazioni sull'aggiornamento degli elementi collegati, vedere Gestire i dati negli elementi collegati.
Creare immagini da Excel
Inserire nella presentazione un'immagine da una cella Excel che contiene l'URL o il percorso del file locale dell'immagine. A tale scopo, seguire questi passaggi:
- In Excel, in una cella vuota, inserire l'URL dell'immagine. Se l'immagine è archiviata nel dispositivo, inserire il percorso file dell'immagine, iniziando con
file://.
- Selezionare la cella che contiene l'URL o il percorso file.
- Sulla barra multifunzione di Excel, selezionare Insert > thinkcell > Link to PowerPoint > Image from URL. PowerPoint si apre.
- In PowerPoint, posizionare l'immagine in una diapositiva.
È anche possibile sostituire un'immagine nella diapositiva con un'immagine da un URL o da un percorso file in Excel. A tale scopo, seguire questa procedura:
- In PowerPoint, selezionare l'immagine da sostituire.
- In Excel, selezionare la cella che contiene l'URL o il percorso del file dell'immagine da usare.
- Scegliere tra le opzioni seguenti:
- In Excel, sulla barra multifunzione, selezionare Insert > thinkcell > Link To PowerPoint > To Existing Element
. PowerPoint si apre. In PowerPoint, selezionare l'immagine da sostituire.
-
In PowerPoint, sulla barra multifunzione, selezionare Insert > thinkcell Data > New Excel Link. In alternativa, fare clic con il pulsante destro del mouse sull'immagine per aprire il menu di scelta rapida, quindi selezionare Establish Excel Link
.
Se l'immagine da sostituire è collegata a Excel, prima di seguire questo passaggio, fare clic con il pulsante destro del mouse sull'immagine per aprire il menu di scelta rapida, quindi selezionare Break Excel Link
.
- In Excel, sulla barra multifunzione, selezionare Insert > thinkcell > Link To PowerPoint > To Existing Element
Passare da un'immagine collegata all'altra usando formule di Excel
Passare tra immagini diverse nella diapositiva da Excel usando formule e riferimenti di cella che restituiscono URL di immagini o percorsi file. A tale scopo, seguire questa procedura:
- In Excel, creare una formula che restituisca gli URL delle immagini o i percorsi file da usare.
- Selezionare la cella che contiene la formula.
- Sulla barra multifunzione di Excel, selezionare Insert > thinkcell > Link to PowerPoint > Image from URL. PowerPoint si apre.
- In PowerPoint, posizionare l'immagine in una diapositiva.
- Per passare da un'immagine all'altra, modificare il valore usato dalla formula, quindi aggiornare l'immagine collegata in PowerPoint.
Ad esempio, la formula di Excel seguente restituisce uno di due percorsi file di immagini, a seconda del valore nella cella F5:
=IF(F5<10,"file://C:\Users\Public\Go_sign.png","file://C:\Users\Public\Slow_sign.png")
Quando si inserisce o si sostituisce un'immagine nella diapositiva con un collegamento dati alla cella della formula, l'immagine collegata cambia in base al valore nella cella F5:
Gestire gli intervalli collegati in Excel
Gli intervalli Excel collegati hanno cornici di collegamento dati con codifica a colori.
Il colore di una cornice di collegamento dati indica lo stato dell'intervallo collegato.
|
Colore della cornice |
Stato del collegamento dati |
|---|---|
|
Verde |
Sono presenti presentazioni aperte con elementi collegati che usano i dati nell'intervallo collegato. |
|
Rosso |
Nessuna presentazione aperta contiene elementi collegati che usano l'intervallo Excel. Possibili motivi:
|
|
Blu |
La cornice del collegamento dati è selezionata. |
Quando gli intervalli Excel collegati non soddisfano perfettamente le esigenze della presentazione, non è necessario spostare le celle o modificarne il contenuto. È possibile Regolare gli intervalli collegati per adattarli ai layout dati degli elementi collegati oppure Disporre i dati di Excel in base agli elementi collegati per organizzarli per gli elementi collegati.
Non è necessario avere PowerPoint aperto durante la regolazione degli intervalli collegati o la compilazione dei dati. Per vedere le modifiche in PowerPoint, aprire una presentazione con elementi collegati che usano i dati nell'intervallo collegato e aggiornare gli elementi collegati (vedere Gestire i dati negli elementi collegati).
Regolare gli intervalli collegati
Esistono tre modi diversi per regolare gli intervalli Excel collegati dopo averli collegati a elementi in PowerPoint:
- Spostare la cornice di collegamento dati
- Aggiungere o rimuovere righe e colonne
- Trasporre e modificare il layout dati degli intervalli collegati
Spostare la cornice di collegamento dati
Includere celle diverse in un intervallo collegato spostando la cornice di collegamento dati. A tale scopo, seguire questa procedura:
- Selezionare la cornice di collegamento dati intorno all'intervallo collegato.
- Trascinare e riposizionare la cornice di collegamento dati sulle celle da includere nel collegamento dati.
Aggiungere o rimuovere righe e colonne
Quando è necessario aggiungere un'altra serie a un grafico collegato o rimuovere una riga da una tabella collegata, ridimensionare la cornice di collegamento dati per includere o escludere celle. A tale scopo, seguire questa procedura:
- Selezionare la cornice di collegamento dati intorno all'intervallo collegato.
- Ridimensionare la cornice di collegamento dati selezionando e trascinando un punto d'angolo.
Trasporre e modificare il layout dati degli intervalli collegati
Gli elementi collegati in PowerPoint usano i layout dei dati predefiniti di thinkcell per interpretare e visualizzare i dati Excel. Ad esempio, quando si crea un istogramma da un intervallo Excel, il grafico usa le righe come serie e le colonne come categorie per impostazione predefinita (vedere Creare grafici da Excel).
È possibile modificare il modo in cui gli elementi collegati interpretano e visualizzano i dati Excel senza modificare o spostare i dati in Excel. A tale scopo, trasporre o modificare il layout dei dati degli intervalli collegati.
Trasporre gli intervalli collegati
Per modificare i valori rappresentati dalle righe e dalle colonne dell'intervallo collegato, come categorie ed etichette di serie, è possibile trasporre gli intervalli Excel collegati. La trasposizione di un intervallo collegato non modifica né sposta i dati in Excel; cambia solo il modo in cui gli elementi collegati visualizzano i dati.
Per trasporre un intervallo collegato, fare clic con il pulsante destro del mouse sulla cornice di collegamento dati intorno all'intervallo collegato, quindi selezionare Transpose Link
Modificare il layout dati degli intervalli collegati
Specificare se determinate righe e colonne negli intervalli Excel collegati rappresentano valori di dati o informazioni facoltative negli elementi collegati, ad esempio serie e categorie, oppure una riga 100%= (vedere Valori assoluti e relativi). A tale scopo, seguire questa procedura:
- In Excel, fare clic con il pulsante destro del mouse sulla cornice di collegamento dati intorno all'intervallo collegato, quindi selezionare Edit Data Layout
.
- Usare le caselle di controllo per specificare come thinkcell interpreta le righe e le colonne nell'intervallo collegato.
Disporre i dati di Excel in base agli elementi collegati
Quando si collegano elementi a Excel, i dati da usare possono essere mescolati con dati non necessari oppure disposti in un formato che non si desidera modificare. Se è necessaria maggiore flessibilità per adattare i dati Excel collegati alla presentazione, considerare le opzioni seguenti:
- Riempire le celle vuote nel foglio di lavoro con riferimenti di cella che riflettano i valori in altre celle, quindi collegare alla presentazione le celle che contengono riferimenti. Ad esempio, inserire
=B5nella cella F8 in modo che F8 mostri sempre il valore nella cella B5. Per usare i dati nella cella B5 senza influire sulla cella, collegare la cella F8 alla presentazione. - Usare riferimenti di cella di Excel tra fogli di lavoro e raccogliere tutti i dati da usare in un foglio di interfaccia dedicato. I fogli di interfaccia consentono di adattare i dati collegati alla presentazione senza alterare i fogli di lavoro originali che contengono i dati. Ad esempio, è possibile arrotondare in modo coerente i valori che compariranno nei grafici collegati usando thinkcell round nelle celle del foglio di interfaccia (vedere Arrotondamento dei dati di Excel).
- Per escludere celle in un intervallo collegato da un grafico, usare la funzione Hide o Group and Outline di Excel. Per mostrare di nuovo i dati nascosti nel grafico, selezionare Unhide in Excel, quindi aggiornare il grafico.
Visualizzare gli intervalli collegati duplicati
Quando si crea un collegamento dati tra PowerPoint ed Excel, thinkcell assegna un ID collegamento dati all'intervallo Excel collegato. Se si crea una copia di una cartella di lavoro o di un foglio di lavoro che contiene un intervallo collegato, gli intervalli collegati nell'originale e nella copia condividono lo stesso ID collegamento dati.
Quando sono presenti più intervalli collegati aperti con lo stesso ID collegamento dati, sotto ogni intervallo collegato vengono visualizzate schede con codifica a colori che mostrano tutti i duplicati aperti. I colori delle schede indicano lo stato degli intervalli collegati.
|
Colore scheda |
Stato del collegamento dati |
|---|---|
|
Verde |
Sono presenti presentazioni aperte con elementi collegati che usano i dati nell'intervallo collegato. |
|
Rosa |
L'intervallo collegato è un'origine dati alternativa inutilizzata (vedere Passare a origini dati alternative). |
Quando si passa il puntatore su una scheda, una descrizione comando mostra il nome del foglio di lavoro e il percorso file della cartella di lavoro che contiene l'intervallo collegato.
Per aprire un foglio di lavoro che contiene un intervallo collegato specifico, selezionare la relativa scheda. La selezione delle schede in Excel non modifica l'origine dati degli elementi collegati in PowerPoint. Per modificare l'origine dati degli elementi collegati, Passare a origini dati alternative con la finestra di dialogo Data Links.
Hai bisogno di risolvere un problema?
Consulta la nostra knowledge base