21. Ссылки на данные Excel

Если в Excel доступны исходные данные для ваших диаграмм, вы можете создать диаграммы напрямую в приложении Excel. Если данные в Excel изменятся, вы сможете обновить диаграммы с помощью команды или think-cell может сделать это автоматически.

21.1
Создание диаграммы на основе данных Excel
21.2
Настройка макета данных
21.3
Обновление связанного элемента
21.4
Создание таблицы на основе Excel
21.5
Создание текстового поля из Excel
21.6
Диалоговое окно «Ссылки на данные»
21.7
Ведение ссылок на данные
21.8
Компиляция данных
21.9
Часто задаваемые вопросы

21.1 Создание диаграммы на основе данных Excel

Допустим, вы хотите воссоздать пример диаграммы из Введение в создание диаграмм, но вместо того, чтобы вводить данные во внутреннюю таблицу в PowerPoint, вы хотите использовать их непосредственно из листа Excel. Вот как данные выглядят в Excel:

пример данных think-cell в Excel

Чтобы создать диаграмму на основе данных Excel, выберите нужный диапазон данных в рабочей книге Excel, в том числе метки рядов (в нашем примере — пусто) и категорий:

выбранные данные ввода think-cell в Excel

Диапазон, который мы выбрали в нашем примере, идеально соответствует стандартной таблице гистограммы с накоплением, где строки представляют ряды, столбцы — категории, метки категорий находятся в первой строке, во второй строке должно быть значение, представляющее 100%, и в первом столбце должны быть метки рядов. Это самый простой случай, поскольку ссылка изначально будет создана с использованием стандартного макета данных для выбранного типа диаграммы. Но это не является строго необходимым, так как интерпретация связанного диапазона ячеек может быть изменена, как объясняется в Настройка макета данных.

Теперь выберите нужный тип диаграммы, в нашем случае гистограмму с накоплением, из меню «Элементы» на панели инструментов think-cell в Excel:

панель инструментов think-cell в Excel

Если нажать на этот пункт меню в Excel, активируется окно PowerPoint. Если PowerPoint еще не запущен, он будет открыт автоматически. Если в PowerPoint указатель мыши наведен на слайд, появится знакомый вам прямоугольник вставки.

Перейдите на слайд, на который вы хотите вставить диаграмму, или вставьте новый слайд и разместите диаграмму как обычно: Щелкните один раз, чтобы принять размер по умолчанию или нажмите кнопку мыши и, удерживая ее, перетащите указатель, чтобы изменить начальный размер диаграммы. Подробное описание размещения, изменения размера и выравнивания новой диаграммы см. в разделе Вставка новой диаграммы.

После вставки диаграмма выглядит и действует так же, как обычная диаграмма think-cell, которая была создана в PowerPoint. Рабочая книга Excel, содержащая связанные данные, будет указана в верхней части диаграммы:

диаграмма think-cell, вставленная в PowerPoint

Сведения о настройке и выборе стиля диаграммы см. в разделах Добавление и удаление меток и Настройка стиля диаграммы.

Примечание. Если вы используете цветной фон ячеек в Excel, вы можете выбрать эти цвета в качестве цвета заливки в связанной диаграмме, включив параметр Использовать функцию «Заполнять сверху» Excel в элементе управления цветовой схемой (см. раздел Цветовая схема). Это особенно полезно, если применять эту функцию вместе с условным форматированием Excel.

Как и при создании новой диаграммы, вы можете связать выбранный диапазон данных в книге Excel с существующей диаграммой в презентации PowerPoint. Просто нажмите на кнопку image  «К существующему элементу» в меню «Элементы» на панели инструментов think-cell в Excel и нажмите в PowerPoint на диаграмму, с которой требуется связать данные.

21.2 Настройка макета данных

Связав диапазон данных с диаграммой, можно изменить интерпретацию данных, используя контекстное меню «Связь Excel», значок «Редактировать макет данных», контекстное меню «Редактировать макет данных» и «Связь Excel», значок «Переставить», кнопки «Переставить ссылку» в контекстном меню think-cell диапазона данных.

Редактируя макет данных, вы можете удалить ненужные или нежелательные специальные строки и столбцы из диапазона данных, как более подробно описано в Редактировать макет данных.

Возвращаясь к примеру выше, поскольку у нас не было меток рядов, мы можем избежать включения пустого первого столбца в наш диапазон данных при вставке диаграммы следующим образом:

  1. Выберите только столбцы данных плюс метки категорий (H1:K4 в нашем примере).
  2. Выберите нужный тип диаграммы в меню «Элементы» (в нашем примере — гистограмма с накоплением) и вставьте ее на слайд, как описано выше.
  3. Выберите зеленую границу диапазона данных в Excel и щелкните по ней правой кнопкой мыши, чтобы открыть контекстное меню.
  4. Выберите контекстное меню «Связь Excel», значок «Редактировать макет данных», «Редактировать макет данных».
  5. Установите флажок в поле «Метки рядов», чтобы отключить столбец в диапазоне данных.
  6. Нажмите на зеленый флажок на диаграмме в PowerPoint для обновления (см. Обновление связанного элемента).

Теперь наш связанный диапазон в Excel выглядит следующим образом и дает такую же итоговую диаграмму, как на рисунке выше:

Связанный диапазон Excel с измененным макетом, показывающий меню «Редактировать макет данных»

Перекодирование диапазона данных приводит к замене данных столбцов на данные строк, что позволяет, например, создавать гистограммы на основе строк, а не столбцов данных.

  1. Выберите зеленую границу диапазона данных в Excel и щелкните по ней правой кнопкой мыши, чтобы открыть контекстное меню.
  2. Выберите image  «Переставить ссылку».
  3. Нажмите на зеленый флажок на диаграмме в PowerPoint для обновления (см. Обновление связанного элемента).
До и после просмотра перестановки связанного диапазона Excel

Опять же, итоговая диаграмма будет такой же, как на рисунке выше.

Примечание. Перекодирование связанного диапазона данных не приводит к обмену данных между строками и столбцами.

21.3 Обновление связанного элемента

Самая важная функция диаграммы, связанной с книгой Excel, — это возможность обновления диаграммы в соответствии с изменениями базовых данных. В нашем примере мы собираемся добавить третий ряд данных. Дважды нажмите на диаграмму, чтобы переключиться на связанный диапазон данных в Excel. Введите дополнительные данные под связанным диапазоном.

Дополнительная запись данных в источнике данных Excel в think-cell

Затем выберите связанный диапазон, нажав на его границу, чтобы открыть пользовательский интерфейс think-cell. Перетащите угол выделения так, чтобы включить в него новые введенные данные:

Выбор дополнительных данных в источнике данных Excel в think-cell Обновленные и новые выбранные данные в источнике данных Excel в think-cell

Наконец, вернитесь в PowerPoint. Если выбрать связанную диаграмму, она будет отмечена, что указывает на наличие обновления связанных данных:

Связанная диаграмма think-cell с зеленым флажком «Ожидается обновление», Плавающая панель инструментов связанной диаграммы think-cell с ожиданием обновления

Нажмите на флажок или кнопку image  «Обновить один раз» на плавающей панели инструментов диаграммы, которая также отмечена зеленым флажком, чтобы включить изменения данных в Excel в диаграмму. Диаграмма будет обновлена, а флажок исчезнет:

Обновленная диаграмма think-cell (в PowerPoint) с внешним источником данных Excel

После обновления кнопка image выделяется на плавающей панели инструментов и не показывает зеленый флажок; в ее подсказке теперь отображается значение «Обновлено». Это означает, что данные, отображаемые на диаграмме, актуальны для связанного диапазона Excel.

Нажмите на кнопку image  «Отменить изменения», чтобы отменить только что внесенные изменения. Теперь эта кнопка будет выделена, а в ее подсказке будет написано «Изменения отменены», что указывает на то, что данные, отображаемые на диаграмме, находятся в состоянии, предшествующем последнему обновлению.

think-cell всегда будет сохранять состояние данных до и после последнего обновления диаграммы в PowerPoint. Вы можете использовать кнопки «Обновить один раз» и «Отменить изменения» для переключения между этими «последним» и «предыдущим» состояниями данных, даже если связанный лист Excel был закрыт или недоступен.

Примечание: Зеленый флажок «Зеленый флажок связи Excel» означает, что существует разница между связанным диапазоном Excel и «последним» и «предыдущим» состоянием данных, сохраненных в диаграмме в PowerPoint. При нажатии на него или на значок «Обновить один раз» , кнопку «Обновить один раз» с этим флажком, сохраняется состояние связанного диапазона Excel как «последнее» на диаграмме в PowerPoint, а состояние, отображаемое на диаграмме при нажатии на него, как «предыдущее».

даже если диаграмма не обновлена или была обновлена, а затем изменения были отменены, ссылка на источник данных Excel сохранится. Таким образом, у вас всегда будет возможность обновить диаграмму позже.

Вы также можете разрешить think-cell автоматически обновлять связанную диаграмму при каждом изменении связанного диапазона Excel. Для этого просто нажмите на значок «Обновить автоматически» , кнопку «Обновить автоматически». Чтобы это сработало, презентация, содержащая диаграмму, и рабочая книга Excel, содержащая связанные данные, должны быть открыты одновременно.

Чтобы снова отключить автоматическое обновление, нажмите на значок «Обновить один раз», «Отключить автоматическое обновление».

Примечание. Привязка диаграммы к данным в Excel с помощью think-cell не зависит от имен файлов Excel или PowerPoint. Каждой диаграмме и каждому диапазону данных в Excel назначается уникальный идентификационный номер, который используется для сохранения связи. Техническое требование для восстановления связи состоит в том, что файл Excel, содержащий диапазон данных, и файл PowerPoint, содержащий диаграмму, должны быть одновременно открыты на одном компьютере, при этом имена файлов не имеют значения.

21.4 Создание таблицы на основе Excel

Помимо диаграмм, вы также можете привязывать диапазон данных в Excel к таблице в PowerPoint:

  1. Выберите нужный диапазон данных в книге Excel, в том числе заголовки столбцов и строк.
  2. Выберите image  «Таблица» в меню «Связать с PowerPoint» на панели инструментов think-cell в Excel.
  3. Разместите таблицу данных на слайде.

Для таблицы в PowerPoint можно изменить размер, позицию и форматирование, как описано в разделе Таблица.

Чтобы добавить на слайд в PowerPoint и диаграмму, и таблицу данных, можно создать их на основе того же диапазона данных в Excel, как описано в разделе Создание диаграммы на основе данных Excel выше для диаграммы и как описано в этом разделе для таблицы.

изображение

В этом случае таблица была размещена под диаграммой, чтобы метки категорий диаграммы также были заголовками столбцов таблицы. При выборе связанного диапазона для таблицы для этого были добавлены только метки последовательностей и значения данных.

Связанная таблица обновляется так же, как и связанная диаграмма, как объяснено в Обновление связанного элемента. Если выбрать любую ячейку связанной таблицы в PowerPoint, вы сможете выбрать обновления вручную или автоматическое обновление, а также отменить последнее обновление. Связанная таблица также отображается в диалоговом окне «Ссылки на данные», как описано в Диалоговое окно «Ссылки на данные».

21.5 Создание текстового поля из Excel

Вы также можете вставить текстовое поле, связанное с ячейкой в Excel, в любую метку think-cell или текстовое поле PowerPoint.

  1. В Excel выберите ячейку с содержимым, на которое вы хотите сделать ссылку.
  2. В PowerPoint установите курсор на метку или текстовое поле.
  3. Выберите значок «Текстовое поле, связанное с Excel» , «Текстовое поле, связанное с Excel» в меню think-cell «Элементы» в PowerPoint.

Зеленый флажок не появляется вверху текстового поля, когда доступно обновление, а отображается только на кнопке «Обновить» на плавающей панели инструментов. В противном случае управление обновлениями содержимого текстового поля происходит точно так же, как описано в Обновление связанного элемента.

21.6 Диалоговое окно «Ссылки на данные»

Если в презентации очень много связанных элементов, искать и обновлять их вручную очень неудобно. Чтобы ознакомиться с обзором элементов и воспользоваться более удобными возможностями их обновления, перейдите в изображение меню Инструменты на панели инструментов think-cell в PowerPoint, а затем откройте диалоговое окно «Ссылки на данные»:

диалоговое окно «Ссылки на данные» think-cell

Диалоговое окно «Ссылки на данные» показывает все связанные элементы в презентации на эскизах слайдов. Элемент помечается зеленым флажком «Зеленый флажок связи Excel» , когда ожидается обновление. Чтобы эти сведения были доступны, файл Excel должен быть открыт. Он отмечен значком «Автоматическое обновление» , если настроен на автоматическое обновление. Вы также можете включить функцию «Выделить на слайде», чтобы дополнительно выделить связанные элементы на слайде; кнопка «Выделить ссылки» на ленте включает эту функцию.

Во втором столбце находится список файлов Excel и URL-адресов Tableau (см. Данные Tableau), которые являются источниками связанных данных. Каждый источник показан рядом с первым слайдом с элементом, связанным с ним.

Связанные диаграммы think-cell текущей презентации и состояние их обновления

При наведении курсора на связанный элемент на эскизе слайда:

  • Источник связанных данных выделен в правом столбце.
  • Подсказка также показывает источник данных, состояние обновления элемента и время последнего изменения его данных.

Щелкните по элементу на эскизе слайда, чтобы выбрать его; PowerPoint также переключится на элемент (в представлении «Обычное») или содержащий его слайд (в представлении «Сортировщик слайдов»). Затем вы можете управлять состоянием и поведением его обновления, используя значок «Обновить один раз» , кнопки «Обновить один раз», image «Отменить изменения» и image «Обновить автоматически» в правом столбце, как объясняется в Обновление связанного элемента, или значок Tableau , кнопку «Обновить вручную» для элементов, связанных с Tableau (см. Данные Tableau).

Двойной щелчок по элементу на миниатюрах слайдов имеет тот же эффект, что и двойной щелчок по самому элементу: Источник данных открыт. Для элементов, связанных с Excel, связанный диапазон будет выбран на листе. Если рабочая книга Excel недоступна, вместо нее открывается внутренняя таблица.

Вы можете оставить диалоговое окно «Ссылки на данные» открытыми во время редактирования слайдов и данных.

Примечание. Если связанный файл Excel для элемента недоступен и пользователь откроет и изменит внутреннюю таблицу, автоматическое обновление связанного элемента будет отключено. Таким образом, любые изменения, внесенные во внутренней таблице, не будут автоматически заменены, когда связанный файл Excel станет доступен.

21.6.1 Множественный выбор и фильтрация

Существуют различные способы выбора более чем одного связанного элемента:

  • Нажмите на файл в правом столбце, чтобы выбрать все элементы, связанные с этим файлом.
  • Щелкните в пустой области на эскизе слайда, чтобы выбрать все связанные элементы на этом слайде.
  • Удерживайте клавишу Ctrl и щелкните по нескольким элементам, чтобы выбрать их. Вы также можете удерживать клавишу Ctrl и щелкнуть по файлам, чтобы выделить все элементы, связанные с этим файлом.
  • Удерживайте клавишу Ctrl и щелкните по нескольким слайдам, чтобы выбрать все элементы на выбранных слайдах.
  • Удерживайте клавишу Shift, чтобы выбрать диапазон слайдов и все диаграммы на них или диапазон файлов и все элементы, связанные с ними.
  • Используйте сочетание клавиш Ctrl+A или нажмите кнопку «Выбрать все», чтобы выбрать все связанные элементы в презентации.

Затем вы можете управлять состоянием обновления и поведением всех выбранных элементов одновременно с помощью кнопок в правом столбце.

Примечание: Вам будут предложены только те кнопки, которые действительно могут быть применены ко всем выбранным элементам. Это означает, что когда ваш выбор содержит элемент, связанный с Tableau (см. Данные Tableau), будет показана только кнопка image «Обновить вручную». Щелчок по ней окажет такое же действие на выбранные ссылки в Excel, как и кнопка «Обновить один раз» , значок «Обновить один раз».

Используйте флажки «Выбор фильтра», чтобы сузить выбор, исключив связанные элементы, которые

  • уже имеют состояние «Обновлено» , значок «Обновить один раз»
  • имеют состояние «Изменения отменены» , значок «Отменить изменения», или ожидают обновления
  • имеют изображение «Автоматическое обновление включено»
  • имеют состояние изображение «Только обновление вручную», так как они связаны с Tableau (см. Данные Tableau).

раздел «Выбор фильтра» в диалоговом окне «Ссылки на данные»

Вы можете снова нажать на флажок, чтобы повторно включить все связанные элементы соответствующего типа, которые были частью первоначального выбора.

Примечание: Чтобы выбрать только связанные элементы данного состояния или типа, сначала нажмите на кнопку «Выбрать все», а затем удалите из выбора все остальные типы.

21.7 Ведение ссылок на данные

После создания связи между данными Excel и диаграммой в PowerPoint, файлы Excel и PowerPoint остаются независимыми друг от друга.

  • Вы можете независимо передавать или редактировать файлы.
  • Вы можете переименовать файлы. Ссылки на данные будут восстановлены, когда файлы Excel и PowerPoint будут открыты одновременно. Чтобы сохранить сведения о восстановленных ссылках на данные, необходимо сохранить файлы.
  • Вы можете скопировать и вставить связанные диаграммы в одной презентации и даже в другой презентации. Копия диаграммы будет связана с тем же источником данных, что и оригинал.
  • Вы можете отправлять файлы Excel и PowerPoint по электронной почте. Ссылки на данные будут восстановлены, когда файлы Excel и PowerPoint будут открыты одновременно на компьютере получателя. Чтобы сохранить сведения о восстановленных ссылках на данные, необходимо сохранить файлы.
  • Вы можете создать копии связанных файлов Excel и использовать их как альтернативные источники данных для ссылок на данные. Оригинал и копии файлов Excel можно редактировать независимо друг от друга. Связь между презентацией PowerPoint и нужным файлом Excel будет установлена, если открыть исходный или скопированный файл Excel вместе с файлом PowerPoint.

Примечание. Если в открытых книгах есть копии одного связанного диапазона в Excel, например после копирования листа, обе копии являются действительными источниками (элементами того же уровня). То, с каким диапазоном будет установлена связь при открытии файла PowerPoint, не определено. На всех диапазонах Excel одного уровня отображаются небольшие пронумерованные вкладки, с помощью которых можно переключаться между ними.

Вкладки используются для переключения между элементами одного уровня в этом диапазоне

Вы должны сделать недоступными все копии связанного диапазона, кроме одной, например, закрыв рабочие книги, содержащие копию ссылки. В качестве альтернативы можно сделать все связанные диапазоны уникальными, удалив все, кроме одной, рамки think-cell в Excel и создав новые ссылки на нужные элементы с помощью кнопки image  «К существующему элементу» в меню «Элементы». Таким образом, каждому новому диапазону будет назначен уникальный идентификатор.

21.7.1 Редактирование связанных файлов

Если вы измените файл PowerPoint, когда файлы Excel недоступны, связанные элементы будут вести себя как обычные элементы с внутренней таблицей. Используя think-cell, можно изменить дизайн и данные элемента без ограничений.

Примечание: Связанные текстовые поля (см. Создание текстового поля из Excel) являются здесь исключением, поскольку они не имеют внутренней таблицы. Если вы хотите изменить текст, просто удалите текстовое поле и введите текст вручную. Это разорвет связь.

Вы также свободно можете изменить книгу Excel, если связанные файлы PowerPoint недоступны. Если надстройка think-cell установлена, все связанные диапазоны данных, которые сейчас не подключены к открытой презентации PowerPoint, будут выделены светло-красной рамкой.

Когда вы откроете источник данных в Excel и содержащую связанный элемент презентацию в PowerPoint одновременно, связь будет восстановлена. В Excel цвет рамки выделения связанного диапазона данных изменится с красного на зеленый. В PowerPoint текущие данные элемента сравниваются с источником данных. Если для элемента задана настройка «Обновить автоматически» , значок «Обновить автоматически», любые изменения данных применяются немедленно. В противном случае, если обнаружены изменения, элемент помечается флажком «Зеленый флажок связи Excel» при выборе и в Диалоговое окно «Ссылки на данные». Затем вы можете управлять обновлением, как объясняется в Обновление связанного элемента.

21.7.2 Изменение и удаление связей

Чтобы отсоединить диаграмму или таблицу от связанного источника данных, просто нажмите на кнопку «Разорвать связь Excel» , значок «Разорвать связь Excel», в контекстном меню элемента:

Удаление внешних ссылок на данные в think-cell

Теперь элемент будет использовать только таблицу think-cell в PowerPoint.

Примечание: Связанные текстовые поля (см. Создание текстового поля из Excel) не имеют контекстного меню. Чтобы разорвать связь связанного текстового поля, выделите его в Диалоговое окно «Ссылки на данные» и нажмите «Удалить».

Таким же образом вы можете отсоединить связанный диапазон данных в Excel от связанных элементов: Выберите связанный диапазон, нажав на его рамку. Когда рамка станет синей, что указывает на выделение в think-cell, щелкните по ней правой кнопкой мыши и нажмите кнопку «Удалить» , значок «Удалить». Рамка think-cell будет удалена, а сами данные сохранятся. Все связанные элементы больше не смогут подключиться к этому диапазону данных как к источнику данных и будут использовать внутренние таблицы.

Примечание: Вы не можете отменить удаление связанной рамки, но можете создать новую связь с существующим элементом, когда потребуется (см. ниже).

При удалении одного участника связи (диапазона данных в Excel или связанного элемента в PowerPoint) другой участник не удаляется. В частности, связанные диапазоны данных в Excel просто остаются на месте, пока их не удалят. Это важно, так как могут существовать другие диаграммы в других презентациях, которые связаны с тем же источником данных.

Примечание: Чтобы удалить все ссылки на данные из презентации, используйте Диалоговое окно «Ссылки на данные». В диалоговом окне нажмите на кнопку «Выбрать все», а затем нажмите клавишу «Удалить», чтобы удалить все такие ссылки за раз.

Чтобы связать существующий элемент с источником данных Excel, сначала откройте рабочую книгу Excel и выберите требуемый диапазон данных. Вы также можете выбрать существующий связанный диапазон, отмеченный цветной рамкой выделения think-cell. Затем выберите «К существующему элементу»  «К существующему элементу» в меню «Элементы». Теперь внимание на PowerPoint: просто щелкните по нужному элементу на слайде, чтобы связать его с выбранным диапазоном Excel.

Примечание: Если выбранный элемент уже связан с внешним источником данных, вновь созданная ссылка заменит предыдущую.

Или же, выбрав нужный диапазон Excel, переключитесь на PowerPoint и выберите нужный элемент. Если элемент уже связан с другим источником данных, отсоедините его, как описано выше. Теперь кнопка «Связь Excel» в контекстном меню элемента изменилась на «Установить связь Excel»  , значок «Установить связь Excel». Нажмите на эту кнопку, чтобы связать выбранный в PowerPoint элемент с выбранным в Excel диапазоном данных.

Примечание: Исключением здесь являются связанные текстовые поля. Они не могут быть связаны с другой ячейкой после их создания.

21.8 Компиляция данных

При создании диаграмм напрямую из Excel у вас, вероятно, уже будут данные в Excel. Однако в некоторых случаях может потребоваться создать диаграмму, используя не все данные на листе Excel. Кроме того, данные могут быть в фиксированном формате, который не так легко изменить.

Как объясняется в Настройка макета данных, вы можете изменить интерпретацию связанного диапазона для лучшего соответствия вашему макету данных. Иногда этих возможностей может быть недостаточно. Вот несколько рекомендаций, которые помогут вам в таких ситуациях.

  • Разместите рамку ссылки на данные think-cell в пустой области листа Excel. Затем используйте ссылки на ячейку Excel, чтобы заполнить рамку think-cell данными из другой части листа. Например, введите =B5 в ячейке F8, чтобы обновлять ее при изменении ячейки B5.
  • Ссылки на ячейки Excel также работают между листами. Вы можете добавить выделенный лист как интерфейсный лист для всех диаграмм, что будет особенно полезно, если вам требуется связать множество диаграмм.
  • Используя выделенный лист как источник для диаграмм, вы сможете подготовить данные специальной для требуемой цели. Например, вы можете использовать округление think-cell, чтобы согласованно округлить данные перед их добавлением на диаграмму (см. раздел Округление данных в Excel).
  • Вы можете легко скрыть целые строки или столбцы данных с диаграммы, используя команду Скрыть в Excel. Помните, что скрытые данные будут показаны на диаграмме, если вы используете команду Показать в Excel и обновите диаграмму.
  • Кроме того, вы можете использовать функцию Excel Группа и структура, чтобы скрыть данные, которые вы не хотите отображать на диаграмме.
Скрытие ячеек таблицы во внешнем источнике данных Excel в think-cell Обновленная диаграмма think-cell после скрытия ячеек таблицы во внешнем источнике данных Excel

21.9 Часто задаваемые вопросы

21.9.1 Что происходит при копировании связанного элемента?

Вы можете копировать связанный элемент так же, как и любой другой, продублировав слайд, продублировав элемент, перетащив элемент, удерживая клавишу Ctrl, или скопировав и вставив элемент в другой слайд или в другую презентацию. В действительности, даже копирование файла презентации позволяет создать копию содержащегося в ней связанного элемента.

В любом случае оригинал и копия неотличимы. Они связаны с одним диапазоном данных Excel, и если открыть их одновременно, оба компонента будут обновлены при изменении данных Excel.

21.9.2 Что происходит при удалении связанного элемента?

При удалении связанного элемента ссылка в PowerPoint удаляется вместе с ним. Если в открытой презентации нет другого элемента, связанного с тем же диапазоном данных, цвет рамки в Excel меняется с зеленого на красный, что указывает на невозможность создания связи.

Другим образом удаление связанного элемента никак не влияет на связанный диапазон данных в Excel. В конце концов, если открыть созданную копию связанного элемента, связь будет восстановлена.

21.9.3 Как избавиться от красных рамок на листах Excel?

Рамки разного цвета на листах Excel обозначают связанные диапазоны данных. Зеленая рамка указывает, что создана связь между диапазоном данных в рамке и элементом в открытой презентации PowerPoint. А красная рамка означает, что ни одна презентация, содержащая связанный элемент, в настоящее время не открыта. Красная рамка не всегда означает, что с этим диапазоном данных не связан ни один элемент. Она просто означает, что в текущих открытых презентациях нет таких элементов.

Если вы уверены, что диапазон данных с рамкой вокруг больше не требуется как источник данных для какого-либо из элементов, вы можете удалить рамку, нажав на кнопку image  «Удалить» в контекстном меню. После этого вместе с рамкой из книги Excel будут удалены сведения о связи. Все элементы, связанные с этим диапазоном данных Excel, не смогут восстановить свои связи в будущем. Вместо этого они будут использовать внутренние таблицы.

На данные Excel это никак не повлияет.

21.9.4 Как узнать, какие элементы в презентации связаны и где находятся связанные источники данных?

Если вы не знаете источники данных элементов в презентации, перейдите в изображение меню Инструменты и откройте диалоговое окно «Ссылки на данные». В диалоговом окне отображается список всех слайдов презентации, содержащих связанные элементы, и указывается их положение на слайде.

Элемент отмечен значком «Автоматическое обновление» , если настроен на автоматическое обновление.

Имя файла Excel, в котором последний раз был найден связанный диапазон данных, также отображается и будет выделено при наведении курсора или выборе связанного с ним элемента.

Подробности см. в разделе Диалоговое окно «Ссылки на данные».

21.9.5 Что происходит со связанным элементом, если его источник данных недоступен?

Если рабочая книга Excel, которая содержит связанный диапазон данных элемента, не открыта и ее не удается найти там, где она находилась раньше, элемент не сможет установить связь. Вместо этого он будет использовать свою внутреннюю таблицу, которая всегда содержит копию связанных данных и позволяет изменять данные, на которых основан элемент.

Внутренняя таблица связанного элемента аналогична таблице обычного элемента. В частности, даже если к одному диапазону Excel привязано несколько элементов, их внутренние таблицы не зависят друг от друга.

Чтобы восстановить связь с диапазоном данных Excel, просто откройте рабочую книгу Excel и презентацию со связанным элементом одновременно. Диаграмма в PowerPoint и данные в Excel будут автоматически связаны. При обновлении элемента с использованием связанных данных все изменения, внесенные в данные во внутренней таблице, будут переопределены.

21.9.6 Как использовать внутреннюю таблицу вместо связанного источника данных Excel?

Чтобы отсоединить элемент от связанного источника данных, просто нажмите на кнопку image  «Разорвать связь Excel» в контекстном меню элемента. Теперь элемент будет использовать только таблицу think-cell в PowerPoint.

Вы можете удалить связь с элементом, независимо от того, открыт ли связанный диапазон данных Excel или нет. Со стороны Excel разрыв связи данных и элемента дает такой же результат, как и удаление элемента.

Дополнительные сведения см. в разделе Изменение и удаление связей.

21.9.7 Как включить или отключить автообновление?

Чтобы включить автоматическое обновление, выберите связанный элемент и нажмите на кнопку «Обновить автоматически» «Обновить автоматически» на плавающей панели инструментов.

Чтобы снова отключить его, нажмите на значок «Обновить один раз», «Отключить автоматическое обновление».

Подробное описание управления поведением обновления см. в Обновление связанного элемента. Те же параметры доступны в Диалоговое окно «Ссылки на данные».

21.9.8 Почему связанный элемент не обновляется, хотя для него включено автообновление?

Связь данных со стороны PowerPoint и со стороны Excel может быть установлена, только если оба файла открыты одновременно. Поэтому если данные в Excel изменятся, когда презентация PowerPoint не открыта, а затем вы откроете презентацию, когда рабочая книга Excel не открыта в то же время, связанные элементы не обнаружат изменения в источниках данных.

Как только книга Excel, содержащая связанный диапазон данных, будет открыта, связь будет восстановлена и изменения будут обнаружены. Если для элемента включено автообновление, он будет обновлен. В противном случае элемент будет отмечен флажком при выборе, а также в Диалоговое окно «Ссылки на данные». Затем вы можете выбрать, хотите ли вы включить измененные данные в элемент или нет.

Дополнительные сведения см. в разделе Обновление связанного элемента.

21.9.9 Почему для связанного элемента указано наличие обновления, хотя данные в Excel не изменились?

Если между открытой презентацией PowerPoint и открытой книгой Excel установлена связь, данные из внутренней таблицы сравниваются со связанным диапазоном данных. Если они не совпадают, элемент отмечается как доступный для обновления. Если автообновление включено, элемент незамедлительно обновляется.

Незавершенное обновление также можно обнаружить, если данные в книге Excel не изменились, но данные во внутренней таблице изменились. Для связанного элемента подключенный диапазон данных Excel имеет приоритет над внутренней таблицей. Поэтому при обновлении любые изменения во внутренней таблице будут потеряны.

Чтобы обеспечить защиту от потери данных, при изменении внутренней таблицы связанного элемента функция автообновления для соответствующего элемента отключается.

Подробное описание поведения обновления и управления им см. в разделе Обновление связанного элемента.

21.9.10 Как связать существующий элемент с диапазоном данных в рабочей книге Excel?

Откройте книгу Excel и выберите требуемый диапазон. Затем выберите «К существующему элементу» выберите  «К существующему элементу» в меню «Элементы». Теперь внимание на PowerPoint: просто щелкните по нужному элементу на слайде, чтобы связать его с выбранным диапазоном Excel.

В качестве альтернативы, после выбора нужного диапазона в Excel, переключитесь в PowerPoint, выберите и щелкните правой кнопкой мыши по нужной диаграмме, а затем нажмите на кнопку image  «Установить связь Excel» в контекстном меню.

Подробности см. в разделе Изменение и удаление связей. Сведения о том, как вставить диаграмму напрямую из Excel, см. в разделе Создание диаграммы на основе данных Excel.

21.9.11 Похоже, что связанная диаграмма игнорирует часть диапазона данных Excel. Почему?

Помимо основных данных, связанный диапазон в Excel по умолчанию содержит несколько ячеек слева и сверху, которые зарезервированы для специальных строк и столбцов, таких как метки категорий и рядов или строка 100%=. Если выбранный диапазон содержит только основные данные, их часть будет интерпретироваться как метки и т. д., и не будет отображаться на диаграмме.

Вы можете изменить связанный диапазон, чтобы он не включал эти специальные строки и столбцы, как объясняется в Настройка макета данных, или, если это позволяет макет вашего листа Excel, вы можете увеличить связанный диапазон данных, перетащив один из маркеров в его углах так, чтобы ваши данные оказались в ячейках данных связанного диапазона (см. также Компиляция данных).

21.9.12 Почему Excel работает медленно при наличии множества связанных диапазонов данных?

Производительность Excel можно повысить, отключив автоматическую проверку ошибок. Для этого откройте диалоговое окно Параметры Excel, выберите Формулы и снимите флажок Включить фоновую проверку ошибок в разделе Проверка ошибок.

21.9.13 Мне необходимо визуализировать много файлов Excel с помощью think-cell. Можно ли запустить think-cell в пакетном режиме?

Вы можете программировать think-cell. Надстройка think-cell предлагает функции для программного обновления диаграмм данными из диапазонов Excel и для создания целых презентаций из шаблонов, см. Автоматизация с использованием данных Excel.

21.9.14 Каковы преимущества по сравнению с Microsoft OLE?

Возможно, вы знакомы с OLE (Object Linking and Embedding) в Microsoft Office. Эта концепция похожа на связи в think-cell и позволяет создавать диаграммы в PowerPoint, которые можно затем обновлять при изменении данных в Excel. Однако методика связывания think-cell имеет ряд преимуществ над OLE.

  • Диаграммы всегда остаются такими же, как и были, независимо от наличия связи. Даже связанные диаграммы — это стандартные объекты PowerPoint а не диаграммы Excel, вставленные в PowerPoint. В частности, данные, на которых основывается диаграмма, также хранятся в презентации, и они могут просматриваться и редактироваться, даже если привязанный файл недоступен.
  • Диаграммы можно связать с Excel в любое время, а не только при их создании.
  • Связанные диаграммы доступны можно редактировать, даже если связанный источник данных недоступен.
  • Связи в think-cell не зависят от имени файла или пути к файлу. Просто откройте оба файла, чтобы восстановить любые существующие связи между ними.

Еще не пользуетесь нашим продуктом?

Рассказать