Knowledge base KB0233
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Conflict with Windows Defender: think-cell does not load or the internal datasheet does not open
Problem 1
After a Windows update, think-cell suddenly no longer loads. Trying to activate think-cell in the PowerPoint options menu has no effect.
Problem 2
After a Windows update, I am unable to open the internal datasheet of think-cell. When I insert a new think-cell chart or double-click an existing think-cell chart, I see the following message:
I already restarted my PC, but the problem continues to occur. Trying to open an email using think-cell's Send Slides... or Request Support... feature fails with a similar message.
For detailed analysis steps, click on Read more
Analysis
- Is think-cell installed in the user account, e.g.,
C:\Users\[your_username]\AppData\Local\think-cell
? You can find your think-cell install directory in PowerPoint: File > Options > Add-Ins in column Location -
If yes, open the Windows Event Viewer and go to the following path:
Application and Services Logs > Microsoft > Windows > Windows Defender > Operational
Go to Actions > Find... and search for
think-cell
. If you find a Warning, select it and check if the General tab shows think-cell's installation path and the ID: 3B576869-A4EC-4529-8536-B80A7769E899, e.g.: - The problem occurs with Windows Defender security intelligence version between 1.353.694.0 and 1.355.1377.0 when the following Windows Defender ASR rules are set.
Cause
If you are using Windows Defender security intelligence version lower than 1.355.1377.0 and the following two Windows Defender ASR rules are set, the execution of either think-cell's tcaddin.dll
or tcasr.exe
is blocked and the file is deleted:
3B576869-A4EC-4529-8536-B80A7769E899
(Block Office applications from creating executable content)c1db55ab-c21a-4637-bb3f-a12568109d35
(Use advanced protection against ransomware)
If the tcaddin.dll
is missing, think-cell cannot load (Problem 1). If the tcasr.exe
is missing, opening the internal datasheet does not work anymore and sending an email via Send Slides… or Request Support… fails with an error message (Problem 2).
Solution
To fix the issue:
- Install the latest Windows Defender security intelligence update, e.g., Windows Start > Settings > Update & Security > Windows Security > Virus & threat protection > Virus & threat protection updates > Check for updates
- Reinstall think-cell to restore missing files.
The problem was fixed by Microsoft. It does not occur with the security intelligence version 1.355.1377.0 or later. To verify your security intelligence version, go to Windows Start > Settings > Update & Security > Windows Security > Virus & threat protection > Settings > About. The latest security intelligence update is available for download on Microsoft's website.
Workaround
If you cannot install the Windows Defender security intelligence update, you can alternatively uninstall your existing think-cell installation and reinstall it as administrator. The problem does not occur with per-machine installations.
Contact support
In case think-cell is installed as administrator or if you cannot find the Warning in the Event Viewer, Windows Defender is not causing the issue to occur. In this case, or if you are still experiencing issues after installing the latest security intelligence update, please contact our support team: Read more
Please send us your think-cell log files for analysis. Since Request Support… does most likely not work, you can find the logs as explained below:
-
Open a new File Explorer window.
-
In the address field, enter
%LOCALAPPDATA%\think-cell
. Select Enter.Alternatively, you can open the
think-cell
folder by browsing the directory: Read moreThe full default filepath is
C:\Users\USERNAME\AppData\Local\think-cell
. ReplaceUSERNAME
with your username.If you can't find this folder, it's probably hidden. To show hidden items, in File Explorer, select one of the following:
- Windows 7: Organize > Folder and search options > View > Show hidden files and folders
- Windows 8, Windows 8.1, and Windows 10: View > Show/hide > Hidden Items
- Windows 11: View > Show > Hidden Items
-
Send all the files in the
think-cell
folder that end inlog
to our support team. These files may include any of the following:-
excel_log.log
-
powerpnt_log.log
-
ppttc_log.log
-
setup_think-cell_VERSION_log.log
-
tcasr_log.log
-
tcindex_log.log
-
tcmail_log.log
-
tcrunxl_log.log
-
tcupdate_log.log
Additionally, if think-cell is active, please send us a screenshot of the About think-cell dialog. To open the About think-cell dialog, on the PowerPoint or Excel ribbon, select Insert > think-cell > Tools
-