KB0233: Conflito com o Windows Defender em que o think-cell não carrega ou a planilha de dados interna não abre

Problema 1

Após uma atualização do Windows, o think-cell não carrega mais. Tentar ativar o think-cell no menu de opções do PowerPoint não tem nenhum efeito.

Problema 2

Depois da atualização do Windows, consigo abrir a planilha de dados interna do think-cell. Quando insiro um novo gráfico* do think-cell ou clico duas vezes em um gráfico* do think-cell existe, vejo a seguinte mensagem:

a think-cell update has been installed

Eu já reiniciei o meu PC, mas o problema continua a ocorrer. Tentar abrir um e-mail usando o recurso Enviar slides… ou Solicitar suporte… do think-cell falha com uma mensagem semelhante.

Para as etapas de análise detalhadas, clique em Ler mais

Análise

  1. O think-cell está instalado na conta do usuário, por exemplo: C:\Users\[your_username]\AppData\Local\think-cell? Você pode localizar o diretório de instalação do think-cell no PowerPoint acessando: Arquivo > Opções > Suplementos, na coluna Local
  2. .

    Se estiver instalado, abra o Visualizador de Eventos do Windows e vá para o seguinte caminho: Registros de Aplicativos e Serviços > Microsoft > Windows > Windows Defender > Operational

    Em seguida, vá em Ações > Localizar... e pesquise por think-cell. Se encontrar um Aviso, selecione-o e verifique se a guia Geral exibe o caminho de instalação do think-cell e o ID: 3B576869-A4EC-4529-8536-B80A7769E899, por exemplo:

    Event Viewer General Tab

  3. O problema ocorre com versões da inteligência de segurança do Windows Defender entre 1.353.694.0 e 1.355.1377.0, quando as seguintes regras de ASR do Windows Defender estão definidas.

Motivo

Se estiver usando a versão de inteligência de segurança do Windows Defender anterior a 1.355.1377.0 e as seguintes duas regras do Windows Defender estiverem definidas, a execução de tcaddin.dll ou de tcasr.exe do think-cell será bloqueada e o arquivo será excluído:

  • 3B576869-A4EC-4529-8536-B80A7769E899
    (Impede que os aplicativos do Office criem conteúdos executáveis)
  • c1db55ab-c21a-4637-bb3f-a12568109d35
    (Utilize proteção avançada contra ransomware)

Se o tcaddin.dll estiver ausente, não é possível carregar o think-cell (Problema 1). Se o tcasr.exe estiver ausente, a abertura da planilha de dados interna não funcionará mais e ocorrerá falha ao enviar um e-mail por meio da opção Enviar slides… ou Solicitar suporte…, com uma mensagem de erro (Problema 2).

Solução

Para corrigir este problema:

  1. Instale a atualização mais recente da inteligência de segurança do Windows Defender, por exemplo: Iniciar do Windows > Configurações > Atualização e Segurança & Segurança do Windows > Proteção contra vírus e ameaças > Atualizações de proteção contra vírus e ameaças & Verificar se há atualizações
  2. Reinstale o think-cell para restaurar os arquivos ausentes.

A Microsoft solucionou o problema, que não ocorro mais em versões da inteligência de segurança 1.355.1377.0 ou superiores. Para verificar a versão da sua inteligência de segurança, acesse: Iniciar do Windows > Configurações > Atualização e Segurança & Segurança do Windows > Proteção contra vírus e ameaças > Configurações & Sobre. A atualização mais recente da inteligência de segurança está disponível para download no site da web da Microsoft.

Solução alternativa

Se não puder instalar a atualização de inteligência de segurança do Windows Defender, você poderá alternativamente desinstalar a sua instalação do think-cell existente e reinstalá-lo como administrador. O problema não ocorre com as instalações por máquina.

Entre em contato com o suporte

No caso de o think-cell ser instalado como administrador ou se você não puder encontrar o Alerta no Exibir de eventos, o Windows Defender não estará causando o problema. Nesse caso, ou se você ainda estiver experimentando problemas depois de instalar a última atualização de inteligência de segurança, favor entrar em contato com a nossa equipe de suporte: Ler mais

Favor nos enviar os seus arquivos de log do think-cell para análise. Uma vez que Solicitar suporte provavelmente não funcionará, você pode encontrar os logs conforme explicado abaixo:

  • Abra uma nova janela do Windows Explorer, digite

    %LOCALAPPDATA%\think-cell

    no campo de endereço e pressione Enter.

  • Envie todos os arquivos com a extensão .log contidos nessa pasta para nossa equipe de suporte.

    Pode ser um dos seguintes arquivos: POWERPNT_log.log, EXCEL_log.log, TCMAIL_log.log, TCUPDATE_log.log, TCRUNXL_log.log, TCASR_log.log, PPTTC_log.log, setup_think-cell_xxxxx_log.log.

  • Se desejar navegar até o diretório: Ler mais

    O caminho de arquivo padrão completo é C:\Users\[USERNAME]\AppData\Local\think-cell. Se não puder encontrar isso, provavelmente está configurado como invisível. Você pode alterar essa definição no Windows Explorer, marcando:

    • Windows 7:
      OpçõesOrganizarPasta e pesquisarExibirMostrar arquivos e pastas ocultas.
    • Windows 8, Windows 8.1 e Windows 10:
      ExibirMostrar/ocultarItens ocultos.

    Além disso, se o think-cell estiver ativo, clique em Ferramentas ícone do Menu Ferramentas Sobre, na barra de ferramentas do think-cell, e envie-nos uma captura de tela da janela informações do think-cell.