KB0233: Conflito com o Windows Defender: o think-cell não carrega ou a planilha de dados não abre
Problema 1
Após uma atualização do Windows, o think-cell não carrega mais. Tentar ativar o think-cell no menu de opções do PowerPoint não tem nenhum efeito.
Problema 2
Depois da atualização do Windows, consigo abrir a planilha de dados interna do think-cell. Quando insiro um novo gráfico* do think-cell ou clico duas vezes em um gráfico* do think-cell existe, vejo a seguinte mensagem:
Eu já reiniciei o meu PC, mas o problema continua a ocorrer. Tentar abrir um e-mail usando o recurso Enviar slides… ou Solicitar suporte… do think-cell falha com uma mensagem semelhante.
Para as etapas de análise detalhadas, clique em Ler mais
Análise
- O think-cell está instalado na conta de usuário, por exemplo.,
C:\Users\[your_username]\AppData\Local\think-cell? Você pode encontrar o seu diretório de instalação do think-cell no PowerPoint: File > Options > Add-Ins na coluna Location -
Se sim, abra o Visualizador de Eventos do Windows, e vá para o seguinte caminho:
Application and Services Logs > Microsoft > Windows > Windows Defender > Operational
Vá para Actions > Find... e pesquise por
think-cell. Se você encontrar um Warning, selecione-o e verifique se a guia General mostra o caminho e a ID de instalação do think-cell: 3B576869-A4EC-4529-8536-B80A7769E899, por exemplo:
- O problema ocorre com a versão de inteligência de segurança do Windows Defender entre as versões 1.353.694.0 e 1.355.1377.0 quando as seguintes regras do Windows Defender ASR estão definidas.
Motivo
Se estiver usando a versão de inteligência de segurança do Windows Defender anterior a 1.355.1377.0 e as seguintes duas regras do Windows Defender estiverem definidas, a execução de tcaddin.dll ou de tcasr.exe do think-cell será bloqueada e o arquivo será excluído:
3B576869-A4EC-4529-8536-B80A7769E899
(Impede que os aplicativos do Office criem conteúdos executáveis)c1db55ab-c21a-4637-bb3f-a12568109d35
(Utilize proteção avançada contra ransomware)
Se o tcaddin.dll estiver ausente, não é possível carregar o think-cell (Problema 1). Se o tcasr.exe estiver ausente, a abertura da planilha de dados interna não funcionará mais e ocorrerá falha ao enviar um e-mail por meio da opção Enviar slides… ou Solicitar suporte…, com uma mensagem de erro (Problema 2).
Solução
Para corrigir este problema:
- Instale a atualização mais recente de inteligência de segurança do Windows Defender, por exemplo, Iniciar do Windows > Settings > Update & Security > Windows Security > Virus & threat protection > Virus & threat protection updates > Check for updates
- Reinstale o think-cell novamente para restaurar os arquivos ausentes.
A Microsoft resolveu o problema. Isso não ocorre com a versão de inteligência da segurança 1.355.1377.0 ou posterior. Para verificar sua versão de inteligência de segurança, acesse Iniciar do Windows > Settings > Update & Security > Windows Security > Virus & threat protection > Settings > About. A última atualização da inteligência da segurança está disponível para download no website da Microsoft.
Solução alternativa
Se não puder instalar a atualização de inteligência de segurança do Windows Defender, você poderá alternativamente desinstalar a sua instalação do think-cell existente e reinstalá-lo como administrador. O problema não ocorre com as instalações por máquina.
Entre em contato com o suporte
No caso de o think-cell ser instalado como administrador ou se você não puder encontrar o Alerta no Exibir de eventos, o Windows Defender não estará causando o problema. Nesse caso, ou se você ainda estiver experimentando problemas depois de instalar a última atualização de inteligência de segurança, favor entrar em contato com a nossa equipe de suporte: Ler mais
Favor nos enviar os seus arquivos de log do think-cell para análise. Uma vez que Solicitar suporte provavelmente não funcionará, você pode encontrar os logs conforme explicado abaixo:
-
Abra uma nova janela do File Explorer.
-
No campo de endereço, digite
%LOCALAPPDATA%\think-cell. Selecione Enter.Como alternativa, você pode abrir a pasta
think-cellnavegando no diretório: Ler maisO caminho de arquivo padrão completo é
C:\Users\USERNAME\AppData\Local\think-cell. SubstituaUSERNAMEpelo seu nome de usuário.Se você não conseguir encontrar esta pasta, ela provavelmente estará oculta. Para mostrar itens ocultos, no Explorador de Arquivos, selecione uma das seguintes opções:
- Windows 7: Organizar > Opções Pasta e pesquisar > Exibir > Mostrar arquivos e pastas ocultas
- Windows 8, Windows 8.1 e Windows 10: Exibir > Mostrar/ocultar > Itens ocultos
- Windows 11: Exibir > Mostrar > Itens ocultos.
-
Envie todos os arquivos na pasta
think-cellque terminam emlogpara nossa equipe de suporte. Esses arquivos podem incluir qualquer um dos seguintes:-
EXCEL_log.log -
POWERPNT_log.log -
ppttc_log.log -
setup_think-cell_VERSION_log.log -
tcasr_log.log -
tcindex_log.log -
tcmail_log.log -
tcrunxl_log.log -
tcupdate_log.log
Além disso, se o think-cell estiver ativo, envie-nos uma captura de tela da caixa de diálogo Sobre o think-cell. Para abrir a caixa de diálogo Sobre o think-cell, na faixa de opções do PowerPoint ou Excel, selecione Inserir > think-cell > Ferramentas
> Ajuda > Sobre.
-