KB0237: Konflikt mit Azure Information Protection-Add-in: Subclassing-Fehler in PowerPoint und Excel

  1. Startseite
  2. Ressourcen
  3. Knowledge Base
  4. KB0237

Problem

Wenn ich PowerPoint oder Excel schließe, erhalte ich die folgende Fehlermeldung:
CRITICALWITHMSG library\ui\win\safesubclassimpl.cpp(392): APIERR 1400 Invalid window handle.

Wenn mehrere PowerPoint- (oder Excel-)Dateien geöffnet sind und die Microsoft Azure Information Protection (AIP)-Leiste unterhalb des Menübands angezeigt wird, kann dieser Fehler beim Schließen der letzten PowerPoint- (oder Excel-)Datei auftreten. Es müssen jedoch auch andere Add-ins vorhanden sein. Das Problem lässt sich zuverlässig reproduzieren, z. B. wenn Capital IQ aktiviert ist. Für detaillierte Schritte zur Reproduktion klicken Sie bitte auf: Mehr lesen

Reproduktion mit thinkcell, Microsoft AIP und Capital IQ:

  1. Öffnen Sie eine neue leere PowerPoint-[oder Excel-]Datei
  2. Öffnen Sie eine zweite neue leere PowerPoint-[oder Excel-]Datei, z. B. mit CTRL+N
  3. Stellen Sie sicher, dass die Microsoft AIP-Leiste unterhalb des Menübands angezeigt wird: Home > Sensitivity> aktivieren Sie Show Bar
  4. Wechseln Sie zur Registerkarte S&P Capital IQ
  5. Charting > Charting > Launch Chart Builder
  6. Schließen Sie die 2. Datei > Don't Save
  7. Schließen Sie die 1. Datei > Don't Save
    > CRITICALWITHMSG library\ui\win\safesubclassimpl.cpp(390): APIERR 1400 Invalid window handle.

Erläuterung

Solche Fehler in thinkcell werden durch einen Programmierfehler in einem anderen Add-in verursacht. Unsere Entwickler haben das Problem eingehend analysiert. In diesem Fall wird das Problem durch das Microsoft Azure Information Protection (AIP)-Add-in verursacht. Nach unserer Analyse verursachen Hooking-/Unhooking-Probleme dieses Problem, wenn mehrere Add-ins vorhanden sind. Mehr lesen

Ein Hook ist ein Mechanismus, mit dem eine Funktion Ereignisse abfangen kann, bevor sie eine Anwendung erreichen. Die Funktion kann auf Ereignisse reagieren und sie in manchen Fällen ändern oder verwerfen. Weitere Einzelheiten finden Sie unter KB0201.

Weitere Add-ins, von denen bekannt ist, dass sie solche Probleme verursachen, sind in KB0169 aufgeführt.

Lösung

Wir haben von Microsoft die Rückmeldung erhalten, dass sich der AIP-Client im Wartungsmodus befindet. Microsoft empfiehlt die Verwendung des AIP-Add-ins für Office nicht, da unter anderem gilt: "Add-ins sind weniger stabil, weil sie mit anderen Add-ins in Konflikt geraten können, was dazu führen kann, dass Office-Apps hängen bleiben, abstürzen oder das Add-in automatisch deaktivieren." Stattdessen empfiehlt Microsoft, die in Office-Apps integrierte Beschriftung von Microsoft Information Protection (MIP) zu verwenden.

Workaround

Das Problem scheint zu verschwinden, wenn die Microsoft AIP-Leiste unterhalb des Menübands in PowerPoint und Excel ausgeschaltet wird. Um sie auszuschalten, gehen Sie zu Home > Sensitivity > deaktivieren Sie Show bar. Bitten Sie in jedem Fall Ihre interne IT um Rat.

Support kontaktieren

Falls weiterhin Probleme ohne das Microsoft AIP-Add-in auftreten, gehen Sie wie folgt vor:

Bitte senden Sie uns die thinkcell Protokolldateien. Wählen Sie hierzu im Menüband von PowerPoint oder Excel Insert > thinkcell > Tools Extras Menüsymbol > Help > Request Support aus. Es öffnet sich eine neue E-Mail mit den automatisch angehängten Protokolldateien.

Wenn Support anfordern weder in PowerPoint noch in Excel funktioniert, führen Sie die folgenden Schritte aus: Mehr lesen

  1. Öffnen Sie ein neues Datei-Explorer-Fenster.

  2. Geben Sie im Adressfeld %LOCALAPPDATA%\think-cell ein. Wählen Sie Enter.

    Alternativ können Sie den think-cell Ordner öffnen, indem Sie folgendes Verzeichnis öffnen: Mehr lesen

    Der vollständige Standarddateipfad ist C:\Users\USERNAME\AppData\Local\think-cell. Ersetzen Sie USERNAME durch Ihren Nutzernamen.

    Wenn Sie diesen Ordner nicht finden, ist er wahrscheinlich ausgeblendet. Um ausgeblendete Elemente anzuzeigen, wählen Sie im Datei-Explorer eine der folgenden Optionen aus:

    • Windows 7: Organisieren > Ordner- und Suchoptionen > Ansicht > Versteckte Dateien und Ordner anzeigen
    • Windows 8, Windows 8.1 und Windows 10: View > Ein-/Ausblenden > Ausgeblendete Elemente
    • Windows 11: Anzeigen > Einblenden > Ausgeblendete Elemente
  3. Senden Sie alle Dateien im think-cell Ordner, die auf log enden, an unser Support-Team. Diese Dateien können Folgendes umfassen:

    • EXCEL_log.log
    • POWERPNT_log.log
    • ppttc_log.log
    • setup_think-cell_VERSION_log.log
    • tcasr_log.log
    • tcindex_log.log
    • tcmail_log.log
    • tcrunxl_log.log
    • tcupdate_log.log
    • Falls thinkcell aktiv ist, senden Sie uns bitte zusätzlich einen Screenshot des Dialogs Über thinkcell. Um den Dialog Über thinkcell zu öffnen, wählen Sie im PowerPoint- oder Excel-Menüband Einfügen > thinkcell > Tools Extras Menüsymbol > Hilfe > Über aus.