KB0187: Sicherheitseinstellungen können verhindern, dass thinkcell geladen wird
- Startseite
- Ressourcen
- Knowledge Base
- KB0187
Problem
Wenn in PowerPoint oder Excel die Registerkarte Insert keine Gruppe thinkcell enthält, verhindern die Sicherheitseinstellungen in diesen Anwendungen möglicherweise, dass thinkcell automatisch geladen wird.
Wenn die Registerkarte Insert die Gruppe thinkcell enthält, die Registerkarte thinkcell aber keine thinkcell-Befehle enthält, siehe KB0243.
Weitere mögliche Ursachen dafür, dass die Gruppe thinkcell auf der Registerkarte Insert fehlt, finden Sie unter KB0004.
Symptome
Wenn Sie PowerPoint starten, wird unter dem Menüband die Meldungsleiste mit der Sicherheitswarnung Application add-ins have been disabled. angezeigt.
Wenn Sie Excel starten, wird unter dem Menüband die Meldungsleiste mit der Sicherheitswarnung Some active content has been disabled. Click for more details. angezeigt.
Wenn die Sicherheitswarnung nicht angezeigt wird, aber thinkcell-Befehle auf der Registerkarte Insert im Menüband von PowerPoint oder Excel fehlen, wechseln Sie zu File > Options > Trust Center > Trust Center Settings > Add-ins. Wenn Require Application Add-ins to be signed by Trusted Publisher ausgewählt ist, lesen Sie die Detaillierte Analyse.
Lösung
Um das Zertifikat von thinkcell manuell zuzulassen, gehen Sie wie folgt vor. Ein Systemadministrator kann das thinkcell-Zertifikat ebenfalls verteilen.
- Starten Sie PowerPoint oder Excel neu.
-
Wählen Sie in der Meldungsleiste neben der Sicherheitswarnung NICHT Enable Content aus. Wechseln Sie stattdessen zu File > Info > Enable Content > Advanced Options.
- Suchen Sie im Dialogfeld Microsoft Office Security Options das thinkcell-Add-In. Wählen Sie Enable all code published by this publisher und anschließend OK aus.
Detaillierte Analyse
Wenn sich der Herausgeber eines Add-ins im Trust Center nicht in der Liste der vertrauenswürdigen Herausgeber befindet, kann eine Sicherheitseinstellung verhindern, dass das Add-in automatisch geladen wird. Mehr lesen
- Wechseln Sie in PowerPoint oder Excel zu File > Options > Trust Center > Trust Center Settings.
- Wechseln Sie ausschließlich zu Testzwecken zu Add-ins und deaktivieren Sie vorübergehend alle Optionen. Starten Sie PowerPoint oder Excel anschließend neu.
Achtung: Behalten Sie diese Einstellungen aus Sicherheitsgründen nicht bei, nachdem Sie die Tests abgeschlossen haben.
- Wenn thinkcell nach Abschluss der vorherigen Schritte funktioniert, empfehlen wir, dass Sie unter Add-ins die Option Require Application Add-ins to be signed by Trusted Publisher auswählen und anschließend OK wählen. Dadurch wird thinkcell zur Liste der vertrauenswürdigen Herausgeber hinzugefügt.
- Um die Liste der vertrauenswürdigen Herausgeber zu finden, wechseln Sie im Dialogfeld Trust Center zu Trusted Publishers. Wenn thinkcell noch nicht in der Liste steht, führen Sie die folgenden Schritte aus: Mehr lesen
- Wechseln Sie im Dialogfeld Trust Center zu Add-ins. Stellen Sie sicher, dass die Option Require Application Add-ins to be signed by Trusted Publisher ausgewählt ist.
- Wechseln Sie zu Message Bar und stellen Sie sicher, dass die Option Show the Message Bar in all applications when active content, such as ActiveX controls and macros, has been blocked ausgewählt ist.
- Führen Sie die unter Lösung beschriebenen Schritte aus.