KB0187: Le impostazioni di sicurezza potrebbero impedire il caricamento di thinkcell

Problema

In PowerPoint o Excel, se la scheda Insert non contiene il gruppo thinkcell, le impostazioni di sicurezza in queste applicazioni potrebbero impedire il caricamento automatico di thinkcell.

Se la scheda Insert contiene il gruppo thinkcell, ma la scheda thinkcell non contiene comandi thinkcell, vedere KB0243.

Per altre possibili cause dell'assenza del gruppo thinkcell dalla scheda Insert, vedere KB0004.

Sintomi

Quando si avvia PowerPoint, la barra dei messaggi viene visualizzata sotto la barra multifunzione con l'avviso di sicurezza Application add-ins have been disabled.

Quando si avvia Excel, la barra dei messaggi viene visualizzata sotto la barra multifunzione con l'avviso di sicurezza Some active content has been disabled. Click for more details.

Se l'avviso di sicurezza non viene visualizzato, ma i comandi thinkcell mancano dalla scheda Insert della barra multifunzione in PowerPoint o Excel, passare a File > Options > Trust Center > Trust Center Settings > Add-ins. Se Require Application Add-ins to be signed by Trusted Publisher è selezionato, vedere Analisi dettagliata.

Soluzione

Per consentire manualmente il certificato di thinkcell, seguire questi passaggi. Un amministratore di sistema può anche distribuire il certificato di thinkcell.

  1. Riavviare PowerPoint o Excel.
  2. Nella barra dei messaggi, accanto all'avviso di sicurezza, NON selezionare Enable Content. Passare invece a File > Info > Enable Content > Advanced Options.

  3. Nella finestra di dialogo Microsoft Office Security Options, individuare il componente aggiuntivo thinkcell. Selezionare Enable all code published by this publisher, quindi selezionare OK.

Analisi dettagliata

Nel Centro protezione, se l'autore di un componente aggiuntivo non è presente nell'elenco degli autori attendibili, un'impostazione di sicurezza potrebbe impedire il caricamento automatico del componente aggiuntivo. Scopri di più

  1. In PowerPoint o Excel, passare a File > Options > Trust Center > Trust Center Settings.
  2. Solo a scopo di test, passare a Add-ins e deselezionare temporaneamente tutte le opzioni. Quindi riavviare PowerPoint o Excel.
  1. Se thinkcell funziona dopo aver completato i passaggi precedenti, è consigliabile che in Add-ins si selezioni Require Application Add-ins to be signed by Trusted Publisher, quindi selezionare OK. In questo modo thinkcell viene aggiunto all'elenco degli autori attendibili.
  1. Per trovare l'elenco degli autori attendibili, nella finestra di dialogo Trust Center, passare a Trusted Publishers. Se thinkcell non è ancora presente nell'elenco, seguire questi passaggi: Scopri di più
    1. Nella finestra di dialogo Trust Center, passare a Add-ins. Assicurarsi che l'opzione Require Application Add-ins to be signed by Trusted Publisher sia selezionata.
    2. Passare a Message Bar e assicurarsi che l'opzione Show the Message Bar in all applications when active content, such as ActiveX controls and macros, has been blocked sia selezionata.
    3. Seguire i passaggi descritti in Soluzione.