KB0239: PowerPoint-Dateigröße steigt mit Microsoft 365 rapide an

  1. Startseite
  2. Ressourcen
  3. Knowledge Base
  4. KB0239

Problem

Das am unmittelbarsten erkennbare Symptom ist, dass die Dateigröße von PowerPoint-Präsentationen ungewöhnlich groß ist, möglicherweise sogar um ein Vielfaches größer als erwartet. In einigen Fällen kann das Problem anschließend dazu führen, dass sich Dateien nur sehr langsam öffnen, bearbeiten und/oder speichern lassen – oder möglicherweise gar nicht mehr geöffnet werden können.

Dieses Problem kann unter den folgenden Bedingungen auftreten:

  • Dateien werden (oder wurden) an einem SharePoint-Speicherort gespeichert
  • Dateien werden (oder wurden) verschlüsselt, z. B. über
    • Azure Information Protection
    • Microsoft Information Protection
    • Microsoft Purview Information Protection
    • Zugriffsbeschränkungen
  • Folien oder Inhalte auf Folien enthalten Tags oder CustomerData-Objekte (thinkcell und viele andere Add-ins verwenden Tags-Objekte wie von Microsoft vorgeschrieben)

Das Kopieren betroffener Folien oder Objekte in andere Präsentationen kann das Problem auf zusätzliche Dateien übertragen, selbst wenn diese die oben genannten Kriterien nicht erfüllen.

Lösung

Microsoft hat eine Fehlerbehebung für dieses Problem veröffentlicht, die derzeit in den neuesten öffentlich bekannten Updates für Microsoft 365 verfügbar ist. Ältere Versionen, die im Monthly Enterprise Channel und Semi-Annual Enterprise Channel verfügbar sind, können vorerst weiterhin betroffen sein.

Eine Tabelle der betroffenen und behobenen Versionen finden Sie unten:

Version

Erster betroffener Build

Fehlerbehebung verfügbar in:

2208

15601.20578

**

2301

16026.20002

**

2302

*

16130.20714

2303

*

**

2304

*

**

2305

*

**

2306

*

16529.20182

2307

*

16626.20000

* - Problem bestand bereits in der Erstversion
** - Keine Fehlerbehebung erwartet

Hinweis: Die Fehlerbehebung von Microsoft verhindert zwar, dass das Problem auftritt, repariert jedoch keine bereits betroffenen Dateien. Es gibt jedoch einige Optionen, um betroffene Dateien zu bereinigen. In Kombination mit der Fehlerbehebung von Microsoft sollte das Problem dadurch behoben werden: Mehr lesen

Der in PowerPoint integrierte Dokumentinspektor kann verwendet werden, um customXML-Daten aus betroffenen Dateien zu entfernen. Wenn Sie dieses Tool verwenden, stellen Sie bitte sicher, dass ausschließlich die Option Custom XML data verwendet wird. Das Entfernen weiterer Inhaltstypen kann unbeabsichtigte Folgen haben, einschließlich des Entfernens von thinkcell-Funktionalität aus dem Dokument.

Wenn Sie thinkcell 12 verwenden, bietet das Tool Bereinigen und schützen eine bequemere Möglichkeit, auf dieselbe Funktionalität zuzugreifen.

Das Entfernen von customXML-Daten auf eine dieser beiden Arten verhindert nicht, dass sie sich erneut ansammeln, wenn Sie eine ungepatchte Version von PowerPoint verwenden, kann das Problem aber zumindest vorübergehend "zurücksetzen".

Falls Sie Dateien haben, die so stark beschädigt sind, dass sie nicht zuverlässig mit PowerPoint geöffnet werden können und daher weder der Dokumentinspektor noch das Clean up-Tool von thinkcell verwendet werden kann, oder wenn die Anzahl der betroffenen Dokumente eine automatisierte Lösung erfordert, wenden Sie sich bitte an unser Support-Team. Wir können möglicherweise helfen.

Analyse

Unsere Entwickler haben das Problem eingehend analysiert. In Fällen, die die oben beschriebenen Bedingungen erfüllen, kann das Öffnen einer Datei, die auf SharePoint gespeichert und verschlüsselt ist, dazu führen, dass PowerPoint diese Funktion in seinem Code aufruft:

PPT::FileIO::CustomerDataXmlReader::DeSerializeCustomerDataFromEncryptedStorage

Diese Funktion wurde ab den aufgeführten PowerPoint-Versionen neu hinzugefügt. Auf SharePoint gespeicherte Dateien enthalten bestimmte customXML-Datendateien, die für das Dateimanagement von SharePoint verwendet werden. Wenn die Codefunktion aufgerufen wird, werden alle im gesamten Dokument enthaltenen customXML-Dateien für jede Folie oder jedes Objekt dupliziert, das einen Tag oder CustomerData enthält. Wenn Sie mit betroffenen Dateien weiterarbeiten, kann sich dieser Datenmüll auch im Verlauf normaler Bearbeitungsvorgänge weiter ansammeln.

Dieses Problem kann ohne thinkcell reproduziert werden. Für detaillierte Schritte zur Reproduktion klicken Sie bitte auf: Mehr lesen

Reproduktion ohne thinkcell:

  1. Öffnen Sie bei inaktivem oder vorübergehend entferntem thinkcell eine neue leere PowerPoint-Präsentation ohne Platzhalter-Textfelder
  2. Fügen Sie ein PowerPoint-Rechteck ein, z. B. über Insert > Illustrations > Shapes
  3. Öffnen Sie das VBA-Fenster (drücken Sie Alt+F11)
  4. Geben Sie im Immediate Window (falls nicht vorhanden, können Sie es mit Ctrl+G aktivieren) Folgendes ein und drücken Sie anschließend Enter:

    ActivePresentation.Slides(1).Shapes(1).Tags.Add "Test", "Tag"

  5. Schließen Sie das VBA-Fenster
  6. Wählen Sie in PowerPoint das Rechteck aus und duplizieren Sie es 30 Mal mit Ctrl+D, sodass insgesamt 31 Rechtecke vorhanden sind (die Reproduktion funktioniert auch mit weniger Formen, die Dateigrößen variieren dann jedoch entsprechend)
  7. Speichern Sie die Präsentation an einem SharePoint-Speicherort

    Das Dokument sollte nach vollständiger Synchronisierung mit SharePoint etwa 54 KB groß sein.

  8. Wechseln Sie nun zur Registerkarte File im PowerPoint-Menüband und wählen Sie Info > Protect Presentation > Restrict Access > Restricted Access:
  9. Aktivieren Sie im angezeigten Berechtigungsdialogfeld das Kontrollkästchen Restrict permission to this presentation und klicken Sie auf OK:
  10. Speichern Sie das Dokument (z. B. durch Drücken von Ctrl+S) und schließen Sie es anschließend vollständig
  11. Öffnen Sie das Dokument erneut
  12. Entfernen Sie die Zugriffsbeschränkung, indem Sie erneut zu File > Info > Protect Presentation > Restrict Access gehen und diesmal Unrestricted Access auswählen
  13. Speichern Sie das Dokument erneut und schließen Sie es anschließend.

    Das Dokument sollte weiterhin 54 KB groß sein, ist jedoch auf etwa 195 KB angewachsen.

  14. Öffnen Sie das Dokument erneut und wiederholen Sie die Schritte 8 bis 13

    Das Dokument sollte weiterhin 54 KB groß sein, ist jedoch auf etwa 5 MB angewachsen.

Wenn man die Dateistruktur untersucht (z. B. indem man die .pptx-Datei kopiert, die Dateierweiterung der Kopie in .zip ändert und anschließend das Archiv extrahiert), sieht man, dass die Anzahl der im Unterordner customXml enthaltenen Dateien item*.xml und itemProps*.xml von jeweils 3 Dateien nach der Synchronisierung mit SharePoint auf jeweils 96 nach der ersten Wiederholung und auf jeweils 2979 nach der zweiten Wiederholung ansteigt.

Es gibt weitere Schritte und Arbeitsabläufe, die ebenfalls zur Duplizierung von customXML-Daten führen können, doch dieser ist am einfachsten zu demonstrieren und hat den deutlichsten Effekt.

Warum thinkcell betroffen ist

thinkcell verwendet keine customXML-Daten, nutzt jedoch Tags in jeder Form und jedem Objekt, das mit thinkcell erstellt wurde. Daher können mit thinkcell erstellte Folien besonders viele markierte Formen enthalten, was aufgrund dieses Problems zu einer extrem schnellen Duplizierung von customXML-Daten führt.