Knowledge base KB0240

Using Send Slides or Request Support with "New Outlook for Windows" fails or opens a mail with "Classic Outlook for Windows"

Problem

After switching to "New Outlook for Windows" new mails generated with think-cell's Send Slides or Request Support functionality either:

  • Fail, displaying one or more errors such as below


  • Opens a new mail using "Classic Outlook for Windows" instead

Cause

"New Outlook for Windows" is currently still in Preview, and does not yet support some features. One limitation is generating new emails with a file attached – as is the case when utilizing think-cell's Send Slides or Request Support features.

The current behavior, apparently by Microsoft's design, is that at present "Classic Outlook" is instead used for select actions that "New Outlook" does not yet support.

You can observe the same problematic behavior without think-cell as follows:

Reproduction without think-cell:

  • Open a new or existing PowerPoint presentation
  • Go to File > Share > Email > Send as Attachment

    This uses PowerPoint's built in email sharing functionality via the Outlook API, which should generate a new email with the current presentation attached. As with think-cell's Send Slides or Request Support features, this mail will open with "Classic Outlook", rather than "New Outlook".

    Alternatively, you can:

  • From the desktop, right-click on a file (ideally one that is not too large) and select Send to > Mail recipient

    Similarly, this generates an email via MAPI, which is also then handled by "Classic Outlook".

Solution

Until "New Outlook" adds support for this basic email functionality, there is unfortunately no alternative aside from allowing "New Outlook" to pass the task on to "Classic Outlook".

As per Microsoft's support page, there is currently no support available for "New Outlook" for Work, School, or Tenant Admin accounts. If you are eligible for "New Outlook" support, you can follow the instructions on the support page to share with Microsoft the need for fully supporting common APIs in "New Outlook".

In case you are seeing an error message like above, you can try to enable/repair the fallback option of using "Classic Outlook" via these steps for:

Windows 10

  1. Launch "Classic Outlook" (it can run simultaneously with "New Outlook")
  2. Close "Classic Outlook" again
  3. Press Start or the Windows key
  4. Open the Windows ⚙ Settings and select Apps > Default apps > Choose default apps by protocol
  5. Find the option MAILTO (URL:MailTo Protocol)
  6. If the current default handler is shown as Outlook (new), click on it and choose Outlook as the default handler
  7. Select the default handler again and change it to Outlook (new)

Windows 11

  1. Launch "Classic Outlook" (it can run simultaneously with "New Outlook")
  2. Close "Classic Outlook" again
  3. Press Start or the Windows key
  4. Open the Windows ⚙ Settings and select Apps > Default apps
  5. In the search field titled Set a default for a file type or link type, enter MAILTO, which should then display the URL:MailToProtocol option
  6. If the current default handler is shown as Outlook (new), click on it and choose Outlook as the default handler
  7. Select the default handler again and change it to Outlook (new)

You should now see that new emails containing attachments are generated with "Classic Outlook", but that mails without attachments are generated with "New Outlook" – for instance, if you click this link.

If that is still not helpful, please contact our support team.

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