KB0214: Excel berechnet die Quellarbeitsmappe unerwartet neu, wenn ich Daten in ein thinkcell-Datenblatt einfüge

  1. Startseite
  2. Ressourcen
  3. Knowledge Base
  4. KB0214

Problem

Die Option Workbook Calculation meines Excels ist unter File > Options > Formulas > Calculation options auf Manual eingestellt. Die Option Recalculate workbook before saving ist aktiviert.

Wenn ich per Kopieren und Einfügen aus dem Arbeitsblatt in ein thinkcell-Datenblatt übertrage, wird die Excel-Quellarbeitsmappe dennoch automatisch neu berechnet. Die Neuberechnung erfolgt nicht, wenn ich denselben Wert innerhalb von oder zwischen Excel-Arbeitsmappen oder -Arbeitsblättern kopiere und einfüge.

Lösung

  • Fügen Sie den Wert als Text ein, indem Sie mit der rechten Maustaste auf die Zelle im thinkcell-Datenblatt klicken und Paste Options: > Paste Special… > Paste As: Text auswählen.
  • Alternativ können Sie in den Excel-Optionen Recalculate workbook before saving deaktivieren (siehe oben unter Problem). Denken Sie daran, die Option bei Bedarf wieder zu aktivieren.

Erläuterung

Das thinkcell-Datenblatt und die Datenblätter nativer PowerPoint-Diagramme in Office 2013 oder Office 2016 verwenden einen separaten Excel-Prozess. In diesem Szenario führt ein standardmäßiger Einfügevorgang dazu, dass Excel die Quellarbeitsmappe so behandelt, als wäre sie gespeichert worden. Dadurch wird die Neuberechnung ausgelöst, wenn die Option Recalculate workbook before saving aktiviert ist. Wir haben bei Microsoft einen Fall eröffnet und um eine Fehlerbehebung gebeten, die bisher nicht implementiert wurde. Wenn Ihr Unternehmen mit Microsoft einen Servicevertrag für den Office-Support abgeschlossen hat und Sie sich wegen einer Lösung an Microsoft wenden möchten, geben Sie bitte folgende Microsoft-interne Fallnummer an: 112060458780009.

Das Verhalten lässt sich mit Office 2013 oder Office 2016 leicht ohne thinkcell reproduzieren. Bei Office 2003 trat es nicht auf. (Es lässt sich auch mit Office 2007 und Office 2010 reproduzieren, wobei ein anderer Ansatz verwendet wird, der hier der Kürze halber ausgelassen wurde. Bitte wenden Sie sich an unser Support-Team, wenn Sie eine Reproduktion für diese Versionen benötigen). Mehr lesen

  1. Starten Sie PowerPoint und erstellen Sie eine neue PowerPoint-Präsentation.
  2. Gehen Sie in PowerPoint zu Insert > thinkcell > Tools Extras Menüsymbol > Deactivate thinkcell.
  3. Starten Sie Excel und öffnen Sie Ihre betroffene Arbeitsmappe.
  4. Konfigurieren Sie in Excel den Berechnungsmodus wie oben unter Problem beschrieben.
  5. Fügen Sie in PowerPoint ein neues natives PowerPoint-Diagramm über Insert > Illustrations > Chart ein.
  6. Das Datenblatt des Diagramms wird automatisch geöffnet. Lassen Sie es geöffnet.
  7. Kopieren Sie den Wert aus Ihrer betroffenen Arbeitsmappe und fügen Sie ihn in das Datenblatt des Diagramms ein.

Ergebnis: Das Einfügen des Werts löst eine Neuberechnung der Quellarbeitsmappe aus.