Base de conocimientos KB0175

Los gráficos vinculados con el vínculo de datos de Excel no se actualizan en el primer recálculo manual después de cambiar los datos

Problema

Si cambia datos en Excel y luego pulsa F9 para iniciar un recálculo manual, el gráfico no cambia. Este problema solo se produce en las circunstancias siguientes:

  • El archivo se guardó en una versión de Excel anterior a la que está utilizando para abrir el archivo.
  • El modo de cálculo de Excel está establecido en manual.
  • Los datos vinculados se calculan, al menos parcialmente, a partir de otros datos de Excel.
  • Todas las celdas de Excel que contienen fórmulas están bloqueadas.

Si el gráfico de think-cell no se actualiza después de copiar/pegar los datos, consulte el artículo de la base de conocimientos KB0163.

Solución

Al abrir por primera vez un libro en una versión de Excel más reciente, cambie datos e inicie un recálculo dos veces con F9. Una vez que el libro se guarde con la versión de Excel más reciente, un solo recálculo será suficiente.

Explicación

El recálculo de Excel se comporta de forma diferente cuando se abre por primera vez un libro guardado en una versión anterior de Excel y cuando se abre un libro creado en la versión actual. Esto se describe en la Ayuda de Excel de Microsoft bajo el título Learn about calculating workbooks that were created in an earlier version of Excel. Si su empresa tiene un contrato de soporte técnico de Microsoft Office y desea ponerse en contacto con Microsoft para solicitar una corrección, puede indicar el número de caso de Microsoft REG:113070110555536.

El problema se puede reproducir sin think-cell.

Un rango de Excel incrustado en un documento de Word, vinculado al libro de origen, presenta el mismo comportamiento:
  1. Abra un nuevo libro en Excel 2007.
  2. Establezca el modo de cálculo en manual; para ello, haga clic en el Botón de Office (esquina superior izquierda de la ventana de Excel) → Opciones de ExcelFórmulas y establezca Cálculo de libro en Manual.
  3. Introduzca los siguientes datos y fórmulas:
    Hoja1!A1: "1"
    Hoja2!A1: "1"
    Hoja2!B1: "Plátanos"
    Hoja2!A2: "2"
    Hoja2!B2: "Naranjas"
    Hoja2!B3: "=BUSCARV(+Hoja1!A1;$A$1:$B$2;2;0)"
  4. Bloquee la celda B3; para ello, haga clic con el botón derecho en la celda → Formato de celdas Proteger Bloqueada.
  5. Guarde el libro en Excel 2007.
  6. Abra el libro en Excel 2010.
  7. Seleccione Hoja2!A1:B3 y copie con Ctrl+C.
  8. Abra Word 2010 con un nuevo documento.
  9. Pegue las celdas de Excel copiadas mediante: Inicio Portapapeles Pegado especial Pegar vínculo: Texto sin formato
  10. En Excel 2010, escriba el valor 2 en Hoja1!A1. Pulse Intro.
  11. Pulse F9.

Resultado: Los datos de Hoja2!B3 se actualizan, pero el rango de celdas vinculadas en Word no se actualiza.