KB0051: I received the error message "An error occurred when displaying the think-cell user interface."

Cause

The think-cell add-in uses DirectX technology to render the think-cell user interface. Not all graphics adapters and graphics drivers provide full, standardized and bug-free support of DirectX.

Solution

To solve the problem, please check the following:

Diagnosis

If updating your system with the latest graphics drivers does not help, please find out if DirectX is available in your current configuration:

  1. Go to StartRun... and type dxdiag.
  2. On the Display tab, DirectX features should be Enabled as shown in the screenshot below. If not, can you click the buttons to enable them?
dxdiag tool for testing hardware acceleration / DirectX support to render think-cell components

Refer to

If DirectDraw Acceleration or Direct3D Acceleration are marked Not Available (see screenshot above) and there is a comment regarding Netmeeting in the textbox at the bottom, then probably Netmeeting is causing the problem.

Last resort

If all else fails, you can try the following:

  • Set the screen resolution and/or color depth to lower values and see if the problem persists. In most cases, think-cell will work with a configuration of 800x600 at 16 bits color depth (32768 or 65536 colors). If this works but your preferred screen resolution and color depth does not, you should consider a hardware upgrade.
  • Contact us at support@think-cell.com. We will try to make our software compatible with your graphics adapter. As soon as we know about a particular problem, we will usually be able to implement a fix or workaround in our software. It will help to know if DirectX is available in your current configuration (see screenhot above).