KB0051: I received the error message "An error occurred when displaying the think-cell user interface."
Cause
The think-cell add-in uses DirectX technology to render the think-cell user interface. Not all graphics adapters and graphics drivers provide full, standardized and bug-free support of DirectX.
Solution
To solve the problem, please check the following:
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First, update the drivers for your graphics adapter to the latest version.
In most cases, you will find the recommended driver updates for your
computer on the website of your computer's manufacturer.
Intel Driver Updates only for Toshiba Tecra A3, but not for A3-S611, A3-S711, A3-S731 notebooks
-
If you are using think-cell chart on a Mac under Parallels Desktop, please disable the 3D Acceleration. For more details see KB0133: When I use think-cell chart under Parallels Desktop, the screen becomes scrambled
- If you are using Pivot® Pro (monitor rotation software), install the latest update of DirectX. You can find the DirectX update at Microsoft's Windows update site:
Diagnosis
If updating your system with the latest graphics drivers does not help, please find out if DirectX is available in your current configuration:
- Go to Start → Run... and type dxdiag.
- On the Display tab, DirectX features should be Enabled as shown in the screenshot below. If not, can you click the buttons to enable them?
Refer to
If DirectDraw Acceleration or Direct3D Acceleration are marked Not Available (see screenshot above) and there is a comment regarding Netmeeting in the textbox at the bottom, then probably Netmeeting is causing the problem.
- If you are using Windows 2000 and Netmeeting is not running while you experience the problem, proceed at KB0053: Netmeeting's Desktop Sharing feature does not shut down
- If you are trying to run Netmeeting while PowerPoint is running, refer to KB0054: Netmeeting appears to crash PowerPoint
Last resort
If all else fails, you can try the following:
- Set the screen resolution and/or color depth to lower values and see if the problem persists. In most cases, think-cell will work with a configuration of 800x600 at 16 bits color depth (32768 or 65536 colors). If this works but your preferred screen resolution and color depth does not, you should consider a hardware upgrade.
- Contact us at support@think-cell.com. We will try to make our software compatible with your graphics adapter. As soon as we know about a particular problem, we will usually be able to implement a fix or workaround in our software. It will help to know if DirectX is available in your current configuration (see screenhot above).

